aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJason Gunthorpe <jgg@mellanox.com>2020-06-14 22:15:03 -0300
committerJason Gunthorpe <jgg@nvidia.com>2020-06-22 20:24:18 -0300
commitb9445b60cb0a1abd1bc437f213a284dfa03fbb74 (patch)
treecd5a0b231ad6641c37b7f7ac6e900f069140ac75 /setup.py
parentbbc4a732f898647d4d298bcf02fdd6623831acfa (diff)
downloadcloud_mdir_sync-b9445b60cb0a1abd1bc437f213a284dfa03fbb74.tar.gz
cloud_mdir_sync-b9445b60cb0a1abd1bc437f213a284dfa03fbb74.tar.bz2
cloud_mdir_sync-b9445b60cb0a1abd1bc437f213a284dfa03fbb74.zip
O365: Stop using MSAL for OAUTH
Since gmail figured out how to use oauth using asyncio and oauthlib, just use it for the O365 flow too. This greatly speeds up refreshing tickets since both graph and OWA scopes can run in parallel. This also makes the dependency list small enough the tool will run with built-in python modules for most distros. Signed-off-by: Jason Gunthorpe <jgg@mellanox.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 0 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3ffbde2..a9fcaf4 100755
--- a/setup.py
+++ b/setup.py
@@ -35,10 +35,8 @@ setup(
'aiohttp>=3.0.1',
'cryptography>=2.8',
'keyring>=21',
- 'msal>=1.0',
'oauthlib>=3.1',
'pyinotify>=0.9.6',
- 'requests>=2.18',
],
include_package_data=True,
zip_safe=False)