aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJason Gunthorpe <jgg@mellanox.com>2020-05-28 16:00:10 -0300
committerJason Gunthorpe <jgg@mellanox.com>2020-05-28 16:13:11 -0300
commit8f7c714265c7644c818a93fbc7928fc6b4d1c30e (patch)
tree63727130e2cb4a66ff32b26c8e0558327a9c279f /setup.py
parent192d633a13adf2d552f4257f4975b066204b9da9 (diff)
downloadcloud_mdir_sync-8f7c714265c7644c818a93fbc7928fc6b4d1c30e.tar.gz
cloud_mdir_sync-8f7c714265c7644c818a93fbc7928fc6b4d1c30e.tar.bz2
cloud_mdir_sync-8f7c714265c7644c818a93fbc7928fc6b4d1c30e.zip
Add cms-oauth
This is a command line program to get the OAUTH tokens from the credential server. It is intended to fit into the 'call a program to get the token' methodology that several tools are implementing. Several options are provided to format the token and a built in SMTP protocol tests that the server is working properly. Signed-off-by: Jason Gunthorpe <jgg@mellanox.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index cfa9f50..1c90fd7 100755
--- a/setup.py
+++ b/setup.py
@@ -25,7 +25,10 @@ setup(
license='GPL',
packages=['cloud_mdir_sync'],
entry_points={
- 'console_scripts': ['cloud-mdir-sync=cloud_mdir_sync.main:main'],
+ 'console_scripts': [
+ 'cloud-mdir-sync=cloud_mdir_sync.main:main',
+ 'cms-oauth=cloud_mdir_sync.cms_oauth_main:main'
+ ],
},
python_requires=">=3.6",
install_requires=[