aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJason Gunthorpe <jgg@mellanox.com>2020-01-10 16:38:52 -0400
committerJason Gunthorpe <jgg@mellanox.com>2020-01-10 16:38:52 -0400
commit2e325c38031bc88568dc065821722dd3e22259cb (patch)
tree04cabe4f38118c483c3e477fc2d980d9b9d45cb4 /setup.py
downloadcloud_mdir_sync-2e325c38031bc88568dc065821722dd3e22259cb.tar.gz
cloud_mdir_sync-2e325c38031bc88568dc065821722dd3e22259cb.tar.bz2
cloud_mdir_sync-2e325c38031bc88568dc065821722dd3e22259cb.zip
Initial commit of cloud_mdir_sync
I have been using for a few months now with no ill effects. Signed-off-by: Jason Gunthorpe <jgg@mellanox.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py40
1 files changed, 40 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..8d77bb2
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,40 @@
+# SPDX-License-Identifier: GPL-2.0+
+#!/usr/bin/env python3
+from setuptools import setup
+
+def readme():
+ with open('README.md') as f:
+ return f.read()
+
+setup(
+ name='cloud-mdir-sync',
+ version='1.0',
+ description='Synchronize cloud mailboxes with a local MailDir',
+ long_description=readme(),
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Operating System :: POSIX :: Linux',
+ 'Topic :: Communications :: Email :: Post-Office',
+ 'Classifier: License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Programming Language :: Python :: 3.6',
+ ],
+ keywords="office365 email maildir",
+ url='http://github.com/jgunthorpe',
+ author='Jason Gunthorpe',
+ author_email='jgg@ziepe.ca',
+ license='GPL',
+ packages=['cloud_mdir_sync'],
+ entry_points={
+ 'console_scripts': ['cloud-mdir-sync=cloud_mdir_sync.main:main'],
+ },
+ python_requires=">=3.6",
+ install_requires=[
+ 'aiohttp>=3.0.1',
+ 'cryptography>=2.8',
+ 'keyring>=21',
+ 'msal>=1.0',
+ 'pyinotify>=0.9.6',
+ 'requests>=2.18',
+ ],
+ include_package_data=True,
+ zip_safe=False)