aboutsummaryrefslogtreecommitdiffstats
path: root/Demos/Host/MassStorageHost/MassStorageHost.h
Commit message (Collapse)AuthorAgeFilesLines
* Delete host mode demos from the root Host demos folder.Dean Camera2009-06-051-85/+0
|
* Moved out each demos' functionality library files (e.g. Ring Buffer library) ↵Dean Camera2009-05-221-1/+2
| | | | to /Lib directories for a better directory structure.
* Rewritten event system to remove all macros, to make user code clearer.Dean Camera2009-05-181-7/+6
| | | | | | | | Fixed incorrect ENDPOINT_EPNUM_MASK mask preventing endpoints above EP3 from being selected (thanks to Jonathan Oakley). Removed STREAM_CALLBACK() macro - callbacks now use regular function definitions to clarify user code. Removed DESCRIPTOR_COMPARATOR() macro - comparators should now use regular function definitions to clarify user code.
* Changed HWB board driver to Buttons driver, to allow for the support of ↵Dean Camera2009-05-061-1/+1
| | | | future boards with more than one mounted GPIO button.
* Fixed SPI driver init function not clearing SPI2X bit when not needed.Dean Camera2009-04-261-1/+1
| | | | | | Fixed PREVENT ALLOW MEDIUM REMOVAL command issuing in the MassStorageHost demo using incorrect parameters (thanks to Mike Alex). Fixed MassStorageHost demo broken due to an incorrect if statement test in MassStore_GetReturnedStatus().
* Renamed Serial_Stream driver to SerialStream to remain consistent with the ↵Dean Camera2009-04-171-1/+1
| | | | rest of the library's naming scheme for files.
* Partial commit: change references to Drivers/AT90USBXXX to Drivers/Peripheral.Dean Camera2009-04-161-1/+1
|
* Fixed GenericHIDHost demo report write routine incorrect for control type ↵Dean Camera2009-04-161-1/+0
| | | | | | | | | | | | | | | | | | requests (thanks to Andrei Krainev). Removed Endpoint_ClearCurrentBank() and Pipe_ClearCurrentBank() in favour of new Endpoint_ClearIN(), Endpoint_ClearOUT(), Endpoint_ClearControlIN(), Endpoint_ClearControlOUT(), Pipe_ClearIN(), Pipe_ClearOUT(), Pipe_ClearControlIN() and Pipe_ClearControlOUT() macros (done to allow for the detection of packets of zero length). Renamed *_ReadWriteAllowed() macros to *_IsReadWriteAllowed() to remain consistent with the rest of the LUFA API. Endpoint_IsSetupReceived() macro has been renamed to Endpoint_IsSETUPReceived(), Endpoint_ClearSetupReceived() macro has been renamed to Endpoint_ClearControlSETUP(), the Pipe_IsSetupSent() macro has been renamed to Pipe_IsSETUPSent() and the Pipe_ClearSetupSent() macro is no longer applicable and should be removed - changes made to compliment the new endpoint and pipe bank management API. Updated all demos, bootloaders and projects to use the new endpoint and pipe management APIs (thanks to Roman Thiel). Updated library doxygen documentation, added groups, changed documentation macro functions to real functions for clarity. Removed old endpoint and pipe aliased read/write/discard routines which did not have an explicit endian specifier for clarity. Removed the ButtLoadTag.h header file, as no one used for its intended purpose anyway.
* All comments in the library, bootloaders, demos and projects have now been ↵Dean Camera2009-04-011-1/+1
| | | | spell-checked and spelling mistakes/typos corrected.
* Seperated out OTG, Device and Host mode demos into seperate folders for ↵Dean Camera2009-03-201-0/+86
clarity. Adjusted makefiles so that the path to the LUFA library can be set in one place.