aboutsummaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Lunt <samuel.j.lunt@gmail.com>2017-11-27 17:07:56 -0600
committerSam Lunt <sam.lunt@transmarketgroup.com>2017-11-27 17:31:07 -0600
commitf46bd00e369ea9948e485ae8f65bef658637dc61 (patch)
treed9d4a808357067f4bc82319e5e40475d61ba676c /googletest/CMakeLists.txt
parentd175c8bf823e709d570772b038757fadf63bc632 (diff)
downloadgoogletest-f46bd00e369ea9948e485ae8f65bef658637dc61.tar.gz
googletest-f46bd00e369ea9948e485ae8f65bef658637dc61.tar.bz2
googletest-f46bd00e369ea9948e485ae8f65bef658637dc61.zip
make includes system
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index b9a920b7..f94d939d 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -103,8 +103,8 @@ target_link_libraries(gtest_main gtest)
# to the targets for when we are part of a parent build (ie being pulled
# in via add_subdirectory() rather than being a standalone build).
if (DEFINED CMAKE_VERSION AND NOT "${CMAKE_VERSION}" VERSION_LESS "2.8.11")
- target_include_directories(gtest INTERFACE "${gtest_SOURCE_DIR}/include")
- target_include_directories(gtest_main INTERFACE "${gtest_SOURCE_DIR}/include")
+ target_include_directories(gtest SYSTEM INTERFACE "${gtest_SOURCE_DIR}/include")
+ target_include_directories(gtest_main SYSTEM INTERFACE "${gtest_SOURCE_DIR}/include")
endif()
########################################################################