aboutsummaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Spiridonov <lesha@fb.com>2019-10-17 00:19:18 -0700
committerAlexey Spiridonov <snarkmaster@gmail.com>2019-10-17 00:32:47 -0700
commitcbf019de22c8dd37b2108da35b2748fd702d1796 (patch)
tree5b36a0cb3f1b7d6879384f765cf9b324326a20ce /googletest/CMakeLists.txt
parentbdc29d5dc19dd802907ea37a80ce5dc9afe0898d (diff)
downloadgoogletest-cbf019de22c8dd37b2108da35b2748fd702d1796.tar.gz
googletest-cbf019de22c8dd37b2108da35b2748fd702d1796.tar.bz2
googletest-cbf019de22c8dd37b2108da35b2748fd702d1796.zip
[googletest] Output skip message
Closes #2208 Previously, skip messages were invisible, so debugging skips was hard. Now we have this: ``` $ ./googletest/gtest_skip_test Running main() from /home/lesha/github/snarkmaster/googletest/googletest/src/gtest_main.cc [==========] Running 3 tests from 2 test suites. [----------] Global test environment set-up. [----------] 1 test from SkipTest [ RUN ] SkipTest.DoesSkip /home/lesha/github/snarkmaster/googletest/googletest/test/gtest_skip_test.cc:38: Skipped skipping single test [ SKIPPED ] SkipTest.DoesSkip (0 ms) [----------] 1 test from SkipTest (1 ms total) ... ```
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index db292946..4fd7b526 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -266,6 +266,7 @@ $env:Path = \"$project_bin;$env:Path\"
cxx_executable(googletest-break-on-failure-unittest_ test gtest)
py_test(googletest-break-on-failure-unittest)
+ py_test(gtest_skip_check_output_test)
py_test(gtest_skip_environment_check_output_test)
# Visual Studio .NET 2003 does not support STL with exceptions disabled.