aboutsummaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorly2048 <31530391+ly2048@users.noreply.github.com>2017-09-14 13:22:04 +0800
committerGitHub <noreply@github.com>2017-09-14 13:22:04 +0800
commit9681b4c8e6aae36ac1d0ae0c4e99bdf013b41913 (patch)
tree2cf04ee41a4bed6c309048e3923fbba2f9567832 /googletest/CMakeLists.txt
parent20e62ad24cc723b5699702c9bf52fd5ae0de6011 (diff)
downloadgoogletest-9681b4c8e6aae36ac1d0ae0c4e99bdf013b41913.tar.gz
googletest-9681b4c8e6aae36ac1d0ae0c4e99bdf013b41913.tar.bz2
googletest-9681b4c8e6aae36ac1d0ae0c4e99bdf013b41913.zip
Add explicit `CMAKE_DEBUG_POSTFIX` option
Enable generating different library name to be compatible with CMake's `FindGTest`.
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index 8391dbd0..b9a920b7 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -27,6 +27,8 @@ option(
"Build gtest with internal symbols hidden in shared libraries."
OFF)
+set(CMAKE_DEBUG_POSTFIX "d" CACHE STRING "Generate debug library name with a postfix.")
+
# Defines pre_project_set_up_hermetic_build() and set_up_hermetic_build().
include(cmake/hermetic_build.cmake OPTIONAL)