aboutsummaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorWojciech Mamrak <wmamrak@gmail.com>2017-12-07 18:17:43 +0100
committerGitHub <noreply@github.com>2017-12-07 18:17:43 +0100
commit8d9d6bb0a3751ef3a7159aa0c2f1efd769d56075 (patch)
tree9dd33ce2d0a542d3708abc9cec67df17f7f7154b /googletest/CMakeLists.txt
parenta868e618c0607259c63f37d948b72586a13922ff (diff)
downloadgoogletest-8d9d6bb0a3751ef3a7159aa0c2f1efd769d56075.tar.gz
googletest-8d9d6bb0a3751ef3a7159aa0c2f1efd769d56075.tar.bz2
googletest-8d9d6bb0a3751ef3a7159aa0c2f1efd769d56075.zip
Improved description of VS std::tuple support
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index b9a920b7..31fef2cd 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -83,6 +83,8 @@ include_directories(
# <= VS 2010 <= 10 <= 1600 Use Google Tests's own tuple.
# VS 2012 11 1700 std::tr1::tuple + _VARIADIC_MAX=10
# VS 2013 12 1800 std::tr1::tuple
+# VS 2015 14 1900 std::tuple
+# VS 2017 15 >= 1910 std::tuple
if (MSVC AND MSVC_VERSION EQUAL 1700)
add_definitions(/D _VARIADIC_MAX=10)
endif()