aboutsummaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorEnji Cooper <yaneurabeya@gmail.com>2019-03-29 21:36:28 -0700
committerEnji Cooper <yaneurabeya@gmail.com>2019-03-30 11:38:03 -0700
commit67c75ff8baf4228e857c09d3aaacd3f1ddf53a8f (patch)
treea53f146cd4c51e7a51b0e2ca73e6c1e1bdcdaff2 /googletest/CMakeLists.txt
parent5b752b1947bbb4df571848a1afad00f9b06f30e0 (diff)
downloadgoogletest-67c75ff8baf4228e857c09d3aaacd3f1ddf53a8f.tar.gz
googletest-67c75ff8baf4228e857c09d3aaacd3f1ddf53a8f.tar.bz2
googletest-67c75ff8baf4228e857c09d3aaacd3f1ddf53a8f.zip
Handle GTEST_SKIP() when calling `Environment::SetUp()`
gtest prior to this change would completely ignore `GTEST_SKIP()` if called in `Environment::SetUp()`, instead of bailing out early, unlike `Test::SetUp()`, which would cause the tests themselves to be skipped. The only way (prior to this change) to skip the tests would be to trigger a fatal error via `GTEST_FAIL()`. Desirable behavior, in this case, when dealing with `Environment::SetUp()` is to check for prerequisites on a system (example, kernel supports a particular featureset, e.g., capsicum), and skip the tests. The alternatives prior to this change would be undesirable: - Failing sends the wrong message to the test user, as the result of the tests is indeterminate, not failed. - Having to add per-test class abstractions that override `SetUp()` to test for the capsicum feature set, then skip all of the tests in their respective SetUp fixtures, would be a lot of human and computational work; checking for the feature would need to be done for all of the tests, instead of once for all of the tests. For those reasons, making `Environment::SetUp()` handle `GTEST_SKIP()`, by not executing the testcases, is the most desirable solution. In order to properly diagnose what happened when running the tests if they are skipped, print out the diagnostics in an ad hoc manner. Update the documentation to note this change and integrate a new test, gtest_skip_in_environment_setup_test, into the test suite. This change addresses #2189. Signed-off-by: Enji Cooper <yaneurabeya@gmail.com>
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index 6e42c5c6..e4b02819 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -222,6 +222,7 @@ $env:Path = \"$project_bin;$env:Path\"
test/gtest-typed-test2_test.cc)
cxx_test(gtest_unittest gtest_main)
cxx_test(gtest-unittest-api_test gtest)
+ cxx_test(gtest_skip_in_environment_setup_test gtest_main)
cxx_test(gtest_skip_test gtest_main)
############################################################