aboutsummaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorGennadiy Civil <gennadiycivil@users.noreply.github.com>2017-12-09 09:38:16 -0500
committerGitHub <noreply@github.com>2017-12-09 09:38:16 -0500
commit59202300f1a774068608caff0351cc084fe79e7c (patch)
tree5d43e76b99147324ee15705b3beb40aa6e85cda4 /googletest/CMakeLists.txt
parentcc372a071bb417c83cd5dbca008bda1c438af4d5 (diff)
parent10ef1d9a1e7e6a0b3701d262cf1b889620fdbbc9 (diff)
downloadgoogletest-59202300f1a774068608caff0351cc084fe79e7c.tar.gz
googletest-59202300f1a774068608caff0351cc084fe79e7c.tar.bz2
googletest-59202300f1a774068608caff0351cc084fe79e7c.zip
Merge pull request #1333 from sam-lunt/use-system-includes
Use system includes
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index 31fef2cd..3b907fd7 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -105,8 +105,8 @@ target_link_libraries(gtest_main gtest)
# to the targets for when we are part of a parent build (ie being pulled
# in via add_subdirectory() rather than being a standalone build).
if (DEFINED CMAKE_VERSION AND NOT "${CMAKE_VERSION}" VERSION_LESS "2.8.11")
- target_include_directories(gtest INTERFACE "${gtest_SOURCE_DIR}/include")
- target_include_directories(gtest_main INTERFACE "${gtest_SOURCE_DIR}/include")
+ target_include_directories(gtest SYSTEM INTERFACE "${gtest_SOURCE_DIR}/include")
+ target_include_directories(gtest_main SYSTEM INTERFACE "${gtest_SOURCE_DIR}/include")
endif()
########################################################################