aboutsummaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorHenry Schreiner <henryschreineriii@utexas.edu>2017-08-18 15:18:58 -0400
committerGitHub <noreply@github.com>2017-08-18 15:18:58 -0400
commit5518a1d350d59b22669440b175a5be045d544c35 (patch)
treec5a55b02ed863054a85162e644fdba9cb7ef3ddb /googletest/CMakeLists.txt
parent1fe692ce49f1fc3c7003d052451e147c9b5f19a6 (diff)
downloadgoogletest-5518a1d350d59b22669440b175a5be045d544c35.tar.gz
googletest-5518a1d350d59b22669440b175a5be045d544c35.tar.bz2
googletest-5518a1d350d59b22669440b175a5be045d544c35.zip
Adding CMake visibility policy setting
This policy setting will silence a warning when using with a visibility settings on targets. Due to the forced `cmake_minimum_version`, policy settings in CMakeLists calling this one (including the main CMakeLists) are lost, forcing the change to be made here.
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index b5414608..59343ed2 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -52,6 +52,10 @@ else()
endif()
cmake_minimum_required(VERSION 2.6.4)
+if (POLICY CMP0063) # Visibility
+ cmake_policy(SET CMP0063 NEW)
+endif (POLICY CMP0063)
+
if (COMMAND set_up_hermetic_build)
set_up_hermetic_build()
endif()