aboutsummaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Neto <dneto@google.com>2018-02-26 14:54:16 -0500
committerDavid Neto <dneto@google.com>2018-02-26 15:58:49 -0500
commit20074be19a9c1d6568a4554da2fee3f2e3dbac09 (patch)
treeb87f723f43db948f12e3d49f1f893472d66f4364 /googletest/CMakeLists.txt
parentac34e6c950925df7165e626becd3f9d64dcd584b (diff)
downloadgoogletest-20074be19a9c1d6568a4554da2fee3f2e3dbac09.tar.gz
googletest-20074be19a9c1d6568a4554da2fee3f2e3dbac09.tar.bz2
googletest-20074be19a9c1d6568a4554da2fee3f2e3dbac09.zip
Use DEBUG_POSTFIX instead of CMAKE_DEBUG_POSTFIX
CMAKE_DEBUG_POSTFIX is a global configuration parameter, and changing it pollutes the configuration space for other projects that enclose this project. DEBUG_POSTFIX is better to use since it is a target-specific poperty. Fixes #1334 Fixes #1268
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index 77b55cae..5c392e2c 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -27,8 +27,6 @@ option(
"Build gtest with internal symbols hidden in shared libraries."
OFF)
-set(CMAKE_DEBUG_POSTFIX "d" CACHE STRING "Generate debug library name with a postfix.")
-
# Defines pre_project_set_up_hermetic_build() and set_up_hermetic_build().
include(cmake/hermetic_build.cmake OPTIONAL)