aboutsummaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorAdam Badura <adam.f.badura@gmail.com>2019-07-11 23:22:35 +0200
committerAdam Badura <adam.f.badura@gmail.com>2019-07-27 22:25:32 +0200
commit1be5ce090707da5449214f6867ac3d2063fe2912 (patch)
treedea325e8a4e56751defca59e4bc0c04fe2573703 /googletest/CMakeLists.txt
parent2134e3fd857d952e03ce76064fad5ac6e9036104 (diff)
downloadgoogletest-1be5ce090707da5449214f6867ac3d2063fe2912.tar.gz
googletest-1be5ce090707da5449214f6867ac3d2063fe2912.tar.bz2
googletest-1be5ce090707da5449214f6867ac3d2063fe2912.zip
Correct CMake to cover Cygwin
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index 52a615d5..db292946 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -188,7 +188,7 @@ if (gtest_build_tests)
"$project_bin = \"${CMAKE_BINARY_DIR}/bin/$<CONFIG>\"
$env:Path = \"$project_bin;$env:Path\"
& $args")
- elseif (MINGW)
+ elseif (MINGW OR CYGWIN)
file(GENERATE OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/RunTest.ps1"
CONTENT
"$project_bin = (cygpath --windows ${CMAKE_BINARY_DIR}/bin)