aboutsummaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorBryan Zimmerman <BryanZim@bazinnovations.com>2017-10-27 14:01:16 -0400
committerBryan Zimmerman <BryanZim@bazinnovations.com>2017-10-27 14:01:16 -0400
commit1ae4096b9c5de4429663e6b0c09bf00e5fb46b16 (patch)
treed47ac0a6cb2beaff884a5b33c614c7a5f14a093e /googletest/CMakeLists.txt
parent3121b2049e30d2579c03f841caf4049a2c45cdcd (diff)
downloadgoogletest-1ae4096b9c5de4429663e6b0c09bf00e5fb46b16.tar.gz
googletest-1ae4096b9c5de4429663e6b0c09bf00e5fb46b16.tar.bz2
googletest-1ae4096b9c5de4429663e6b0c09bf00e5fb46b16.zip
fix for VS2017 deprecation of ::tr1::tuple
change static_cast to ImplicitCast_ for consitency fixes for building with path names containing spaces
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt18
1 files changed, 10 insertions, 8 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index b9a920b7..8d4ab405 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -74,8 +74,8 @@ config_compiler_and_linker() # Defined in internal_utils.cmake.
# Where Google Test's .h files can be found.
include_directories(
- ${gtest_SOURCE_DIR}/include
- ${gtest_SOURCE_DIR})
+ "${gtest_SOURCE_DIR}/include"
+ "${gtest_SOURCE_DIR}")
# Summary of tuple support for Microsoft Visual Studio:
# Compiler version(MS) version(cmake) Support
@@ -83,10 +83,12 @@ include_directories(
# <= VS 2010 <= 10 <= 1600 Use Google Tests's own tuple.
# VS 2012 11 1700 std::tr1::tuple + _VARIADIC_MAX=10
# VS 2013 12 1800 std::tr1::tuple
+# VS 2015 14 1900 std::tuple
+# VS 2017 15 1910 std::tuple
if (MSVC AND MSVC_VERSION EQUAL 1700)
add_definitions(/D _VARIADIC_MAX=10)
endif()
-
+
########################################################################
#
# Defines the gtest & gtest_main libraries. User tests should link
@@ -112,11 +114,11 @@ endif()
# Install rules
if(INSTALL_GTEST)
install(TARGETS gtest gtest_main
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
- install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest
- DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}"
+ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}"
+ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}")
+ install(DIRECTORY "${gtest_SOURCE_DIR}/include/gtest"
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}")
# configure and install pkgconfig files
configure_file(