aboutsummaryrefslogtreecommitdiffstats
path: root/googlemock/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Lunt <samuel.j.lunt@gmail.com>2017-11-27 17:07:56 -0600
committerSam Lunt <sam.lunt@transmarketgroup.com>2017-11-27 17:31:07 -0600
commitf46bd00e369ea9948e485ae8f65bef658637dc61 (patch)
treed9d4a808357067f4bc82319e5e40475d61ba676c /googlemock/CMakeLists.txt
parentd175c8bf823e709d570772b038757fadf63bc632 (diff)
downloadgoogletest-f46bd00e369ea9948e485ae8f65bef658637dc61.tar.gz
googletest-f46bd00e369ea9948e485ae8f65bef658637dc61.tar.bz2
googletest-f46bd00e369ea9948e485ae8f65bef658637dc61.zip
make includes system
Diffstat (limited to 'googlemock/CMakeLists.txt')
-rw-r--r--googlemock/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
index 724fdd5f..a4e98afb 100644
--- a/googlemock/CMakeLists.txt
+++ b/googlemock/CMakeLists.txt
@@ -101,8 +101,8 @@ cxx_library(gmock_main
# to the targets for when we are part of a parent build (ie being pulled
# in via add_subdirectory() rather than being a standalone build).
if (DEFINED CMAKE_VERSION AND NOT "${CMAKE_VERSION}" VERSION_LESS "2.8.11")
- target_include_directories(gmock INTERFACE "${gmock_SOURCE_DIR}/include")
- target_include_directories(gmock_main INTERFACE "${gmock_SOURCE_DIR}/include")
+ target_include_directories(gmock SYSTEM INTERFACE "${gmock_SOURCE_DIR}/include")
+ target_include_directories(gmock_main SYSTEM INTERFACE "${gmock_SOURCE_DIR}/include")
endif()
########################################################################