aboutsummaryrefslogtreecommitdiffstats
path: root/googlemock/CMakeLists.txt
diff options
context:
space:
mode:
authorGennadiy Civil <gennadiycivil@users.noreply.github.com>2018-08-17 13:31:01 -0400
committerGitHub <noreply@github.com>2018-08-17 13:31:01 -0400
commitedc1bc606eb46c6786710a6e6303bb91400b2fe0 (patch)
tree3efa24596fe5d94d9b82ca8070ffa70852a8520a /googlemock/CMakeLists.txt
parent7e7e3a6f45db62d470c9d15b062582e9e95d3bcd (diff)
parent02a8ca87735601466d8c564344f9be493da84708 (diff)
downloadgoogletest-edc1bc606eb46c6786710a6e6303bb91400b2fe0.tar.gz
googletest-edc1bc606eb46c6786710a6e6303bb91400b2fe0.tar.bz2
googletest-edc1bc606eb46c6786710a6e6303bb91400b2fe0.zip
Merge branch 'master' into patch-1
Diffstat (limited to 'googlemock/CMakeLists.txt')
-rw-r--r--googlemock/CMakeLists.txt18
1 files changed, 14 insertions, 4 deletions
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
index 0b1f77ae..07b6ad28 100644
--- a/googlemock/CMakeLists.txt
+++ b/googlemock/CMakeLists.txt
@@ -5,10 +5,6 @@
# ctest. You can select which tests to run using 'ctest -R regex'.
# For more options, run 'ctest --help'.
-# BUILD_SHARED_LIBS is a standard CMake variable, but we declare it here to
-# make it prominent in the GUI.
-option(BUILD_SHARED_LIBS "Build shared libraries (DLLs)." OFF)
-
option(gmock_build_tests "Build all of Google Mock's own tests." OFF)
# A directory to find Google Test sources.
@@ -55,6 +51,20 @@ endif()
# if they are the same (the default).
add_subdirectory("${gtest_dir}" "${gmock_BINARY_DIR}/gtest")
+
+# These commands only run if this is the main project
+if(CMAKE_PROJECT_NAME STREQUAL "gmock" OR CMAKE_PROJECT_NAME STREQUAL "googletest-distribution")
+
+ # BUILD_SHARED_LIBS is a standard CMake variable, but we declare it here to
+ # make it prominent in the GUI.
+ option(BUILD_SHARED_LIBS "Build shared libraries (DLLs)." OFF)
+
+else()
+
+ mark_as_advanced(gmock_build_tests)
+
+endif()
+
# Although Google Test's CMakeLists.txt calls this function, the
# changes there don't affect the current scope. Therefore we have to
# call it again here.