aboutsummaryrefslogtreecommitdiffstats
path: root/googlemock/CMakeLists.txt
diff options
context:
space:
mode:
authorGennadiy Civil <gennadiycivil@users.noreply.github.com>2017-08-11 09:14:49 -0400
committerGitHub <noreply@github.com>2017-08-11 09:14:49 -0400
commite3bd4cbeaeef3cee65a68a8bd3c535cb779e9b6d (patch)
treea92ea44a339192eef0f794411397736fc3fcc402 /googlemock/CMakeLists.txt
parentc81be0f6fc06190b6b02a336ac85db77602b16e9 (diff)
parent0e8e0e07d6c4bc8c9cd6df5407452c12752ab45c (diff)
downloadgoogletest-e3bd4cbeaeef3cee65a68a8bd3c535cb779e9b6d.tar.gz
googletest-e3bd4cbeaeef3cee65a68a8bd3c535cb779e9b6d.tar.bz2
googletest-e3bd4cbeaeef3cee65a68a8bd3c535cb779e9b6d.zip
Merge pull request #1160 from mwoehlke-kitware/honor-lib_suffix
Fix library install destinations
Diffstat (limited to 'googlemock/CMakeLists.txt')
-rw-r--r--googlemock/CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
index 9fb96a4b..c3c8aaeb 100644
--- a/googlemock/CMakeLists.txt
+++ b/googlemock/CMakeLists.txt
@@ -103,10 +103,14 @@ endif()
########################################################################
#
# Install rules
-install(TARGETS gmock gmock_main
- DESTINATION lib)
-install(DIRECTORY ${gmock_SOURCE_DIR}/include/gmock
- DESTINATION include)
+if(INSTALL_GMOCK)
+ install(TARGETS gmock gmock_main
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ install(DIRECTORY ${gmock_SOURCE_DIR}/include/gmock
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+endif()
########################################################################
#