aboutsummaryrefslogtreecommitdiffstats
path: root/googlemock/CMakeLists.txt
diff options
context:
space:
mode:
authorJoan Puigcerver <joapuipe@gmail.com>2015-12-03 09:33:21 +0100
committerJoan Puigcerver <joapuipe@gmail.com>2015-12-03 09:33:21 +0100
commit7c8ac4886a7ad513430d132c446a93c6d395345a (patch)
tree895d0f063c1bfb3f9535ea46a254b26a77af0ab5 /googlemock/CMakeLists.txt
parent1f8fe13618a5b23c937140a7c9ad498cd93392e1 (diff)
downloadgoogletest-7c8ac4886a7ad513430d132c446a93c6d395345a.tar.gz
googletest-7c8ac4886a7ad513430d132c446a93c6d395345a.tar.bz2
googletest-7c8ac4886a7ad513430d132c446a93c6d395345a.zip
Added CMake install rules for GMock
Diffstat (limited to 'googlemock/CMakeLists.txt')
-rw-r--r--googlemock/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
index cd522776..7f330c5e 100644
--- a/googlemock/CMakeLists.txt
+++ b/googlemock/CMakeLists.txt
@@ -94,6 +94,14 @@ cxx_library(gmock_main
########################################################################
#
+# Install rules
+install(TARGETS gmock gmock_main
+ DESTINATION lib)
+install(DIRECTORY ${gmock_SOURCE_DIR}/include/gmock
+ DESTINATION include)
+
+########################################################################
+#
# Google Mock's own tests.
#
# You can skip this section if you aren't interested in testing