aboutsummaryrefslogtreecommitdiffstats
path: root/googlemock/CMakeLists.txt
diff options
context:
space:
mode:
authorGennadiy Civil <gennadiycivil@users.noreply.github.com>2017-12-08 15:11:13 -0500
committerGitHub <noreply@github.com>2017-12-08 15:11:13 -0500
commit10ef1d9a1e7e6a0b3701d262cf1b889620fdbbc9 (patch)
tree5d43e76b99147324ee15705b3beb40aa6e85cda4 /googlemock/CMakeLists.txt
parentce919c3ddf8084173bf2050e7e32a91b0818777c (diff)
parentcc372a071bb417c83cd5dbca008bda1c438af4d5 (diff)
downloadgoogletest-10ef1d9a1e7e6a0b3701d262cf1b889620fdbbc9.tar.gz
googletest-10ef1d9a1e7e6a0b3701d262cf1b889620fdbbc9.tar.bz2
googletest-10ef1d9a1e7e6a0b3701d262cf1b889620fdbbc9.zip
Merge branch 'master' into use-system-includes
Diffstat (limited to 'googlemock/CMakeLists.txt')
-rw-r--r--googlemock/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
index a4e98afb..ead51bf3 100644
--- a/googlemock/CMakeLists.txt
+++ b/googlemock/CMakeLists.txt
@@ -74,6 +74,8 @@ include_directories("${gmock_SOURCE_DIR}/include"
# <= VS 2010 <= 10 <= 1600 Use Google Tests's own tuple.
# VS 2012 11 1700 std::tr1::tuple + _VARIADIC_MAX=10
# VS 2013 12 1800 std::tr1::tuple
+# VS 2015 14 1900 std::tuple
+# VS 2017 15 >= 1910 std::tuple
if (MSVC AND MSVC_VERSION EQUAL 1700)
add_definitions(/D _VARIADIC_MAX=10)
endif()