aboutsummaryrefslogtreecommitdiffstats
path: root/googlemock/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthieu Longo <mateo.longo@gmail.com>2018-09-18 12:34:56 +0200
committerMatthieu Longo <matthieu.longo@murex.com>2018-09-18 18:28:29 +0200
commit0a18c106ac0a794b9d912d46b5de20634b14703b (patch)
treee3686e125e9ed2c0a4c82ecd730adba729f7c79d /googlemock/CMakeLists.txt
parentbc2d0935b74917be0821bfd834472ed9cc4a3b5b (diff)
downloadgoogletest-0a18c106ac0a794b9d912d46b5de20634b14703b.tar.gz
googletest-0a18c106ac0a794b9d912d46b5de20634b14703b.tar.bz2
googletest-0a18c106ac0a794b9d912d46b5de20634b14703b.zip
[msys] pass big object file option to assembler for target gmock-matchers_test
Diffstat (limited to 'googlemock/CMakeLists.txt')
-rw-r--r--googlemock/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
index 8a8de1f6..2a913080 100644
--- a/googlemock/CMakeLists.txt
+++ b/googlemock/CMakeLists.txt
@@ -157,6 +157,9 @@ if (gmock_build_tests)
cxx_test(gmock-generated-matchers_test gmock_main)
cxx_test(gmock-internal-utils_test gmock_main)
cxx_test(gmock-matchers_test gmock_main)
+ if (MINGW)
+ target_compile_options(gmock-matchers_test PRIVATE "-Wa,-mbig-obj")
+ endif()
cxx_test(gmock-more-actions_test gmock_main)
cxx_test(gmock-nice-strict_test gmock_main)
cxx_test(gmock-port_test gmock_main)