aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorzhanyong.wan <zhanyong.wan@8415998a-534a-0410-bf83-d39667b30386>2009-06-11 04:04:06 +0000
committerzhanyong.wan <zhanyong.wan@8415998a-534a-0410-bf83-d39667b30386>2009-06-11 04:04:06 +0000
commit07587e9db4145baef2e1cf859bf2b9986326a237 (patch)
tree86710e5ab6f815d9218583c1c5e0dd8126b77bbe /Makefile.am
parentbf55085d456e3ee55eb234c98c435e54d0a2d5aa (diff)
downloadgoogletest-07587e9db4145baef2e1cf859bf2b9986326a237.tar.gz
googletest-07587e9db4145baef2e1cf859bf2b9986326a237.tar.bz2
googletest-07587e9db4145baef2e1cf859bf2b9986326a237.zip
Works around a gcc bug that causes tr1/tuple to fail to compile when RTTI is disabled.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7a821a02..927c4982 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -135,6 +135,16 @@ check_PROGRAMS += test/gmock_test
test_gmock_test_SOURCES = test/gmock_test.cc
test_gmock_test_LDADD = $(GTEST_LIBS) lib/libgmock_main.la
+# A sanity test for verifying that Google Mock works when RTTI is
+# disabled. We pick gmock-spec-builders_test.cc as it exercises all
+# components of Google Mock.
+TESTS += test/gmock_no_rtti_test
+check_PROGRAMS += test/gmock_no_rtti_test
+test_gmock_no_rtti_test_SOURCES = test/gmock-spec-builders_test.cc \
+ src/gmock-all.cc
+test_gmock_no_rtti_test_CXXFLAGS = $(AM_CXXFLAGS) -fno-rtti -DGTEST_HAS_RTTI=0
+test_gmock_no_rtti_test_LDADD = $(GTEST_LIBS)
+
# The following tests depend on the presence of a Python installation and are
# keyed off of it. We only add them to the TESTS variable when a Python
# interpreter is available. TODO(chandlerc@google.com): While we currently only