aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGennadiy Civil <gennadiycivil@users.noreply.github.com>2017-08-11 09:14:49 -0400
committerGitHub <noreply@github.com>2017-08-11 09:14:49 -0400
commite3bd4cbeaeef3cee65a68a8bd3c535cb779e9b6d (patch)
treea92ea44a339192eef0f794411397736fc3fcc402 /CMakeLists.txt
parentc81be0f6fc06190b6b02a336ac85db77602b16e9 (diff)
parent0e8e0e07d6c4bc8c9cd6df5407452c12752ab45c (diff)
downloadgoogletest-e3bd4cbeaeef3cee65a68a8bd3c535cb779e9b6d.tar.gz
googletest-e3bd4cbeaeef3cee65a68a8bd3c535cb779e9b6d.tar.bz2
googletest-e3bd4cbeaeef3cee65a68a8bd3c535cb779e9b6d.zip
Merge pull request #1160 from mwoehlke-kitware/honor-lib_suffix
Fix library install destinations
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 30486302..96cdadef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,10 +8,22 @@ project( googletest-distribution )
enable_testing()
+include(CMakeDependentOption)
+if (CMAKE_VERSION VERSION_LESS 2.8.5)
+ set(CMAKE_INSTALL_BINDIR "bin" CACHE STRING "User executables (bin)")
+ set(CMAKE_INSTALL_LIBDIR "lib${LIB_SUFFIX}" CACHE STRING "Object code libraries (lib)")
+ set(CMAKE_INSTALL_INCLUDEDIR "include" CACHE STRING "C header files (include)")
+ mark_as_advanced(CMAKE_INSTALL_BINDIR CMAKE_INSTALL_LIBDIR CMAKE_INSTALL_INCLUDEDIR)
+else()
+ include(GNUInstallDirs)
+endif()
+
option(BUILD_GTEST "Builds the googletest subproject" OFF)
+cmake_dependent_option(INSTALL_GTEST "Enable installation of googletest. (Projects embedding googletest may want to turn this OFF.)" ON "BUILD_GTEST OR BUILD_GMOCK" OFF)
#Note that googlemock target already builds googletest
option(BUILD_GMOCK "Builds the googlemock subproject" ON)
+cmake_dependent_option(INSTALL_GMOCK "Enable installation of googlemock. (Projects embedding googlemock may want to turn this OFF.)" ON "BUILD_GMOCK" OFF)
if(BUILD_GMOCK)
add_subdirectory( googlemock )