aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorvladlosev <vladlosev@861a406c-534a-0410-8894-cb66d6ee9925>2010-05-18 21:08:05 +0000
committervladlosev <vladlosev@861a406c-534a-0410-8894-cb66d6ee9925>2010-05-18 21:08:05 +0000
commitc828e171752e67ebba33197ba758a4f24188efcf (patch)
tree5b2ff1d3b9d0a4b9ad1b1bfb0bd59be180e4a52b /CMakeLists.txt
parent55d166a2228d7e3b3500b8651ab9b8e56fb43b7e (diff)
downloadgoogletest-c828e171752e67ebba33197ba758a4f24188efcf.tar.gz
googletest-c828e171752e67ebba33197ba758a4f24188efcf.tar.bz2
googletest-c828e171752e67ebba33197ba758a4f24188efcf.zip
Introduces gtest_force_shared_crt option for CMake build scripts.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb43ad19..4a978a1a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,13 @@
# make it prominent in the GUI.
option(BUILD_SHARED_LIBS "Build shared libraries (DLLs)." OFF)
+# When other libraries are using a shared version of runtime libraries,
+# Google Test also has to use one.
+option(
+ gtest_force_shared_crt
+ "Use shared (DLL) run-time lib even when Google Test is built as static lib."
+ OFF)
+
option(gtest_build_tests "Build all of gtest's own tests." OFF)
option(gtest_build_samples "Build gtest's sample programs." OFF)