aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2013-09-06 22:50:25 +0000
committerzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2013-09-06 22:50:25 +0000
commitc306ef2e14483dbf4f047a3e1ca3f86111b800ca (patch)
treebe89ba3a0f06a281e3c5e40cb230c5baf0a65a80 /CMakeLists.txt
parent492986a5d05687853174862efc8e70fe31598eba (diff)
downloadgoogletest-c306ef2e14483dbf4f047a3e1ca3f86111b800ca.tar.gz
googletest-c306ef2e14483dbf4f047a3e1ca3f86111b800ca.tar.bz2
googletest-c306ef2e14483dbf4f047a3e1ca3f86111b800ca.zip
supports a protocol for catching tests that prematurely exit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 81107665..57470c84 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,6 +124,8 @@ if (gtest_build_tests)
test/gtest-param-test2_test.cc)
cxx_test(gtest-port_test gtest_main)
cxx_test(gtest_pred_impl_unittest gtest_main)
+ cxx_test(gtest_premature_exit_test gtest
+ test/gtest_premature_exit_test.cc)
cxx_test(gtest-printers_test gtest_main)
cxx_test(gtest_prod_test gtest_main
test/production.cc)