aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2010-10-05 19:22:50 +0000
committerzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2010-10-05 19:22:50 +0000
commit9c482422587e01545f9da375bf585e4251816afc (patch)
tree847998aad0d2005d8681f9eb5d23b97a2cd2ddff /CMakeLists.txt
parente5974e3f43b4f84d2cd9640a607800ae3447b4f4 (diff)
downloadgoogletest-9c482422587e01545f9da375bf585e4251816afc.tar.gz
googletest-9c482422587e01545f9da375bf585e4251816afc.tar.bz2
googletest-9c482422587e01545f9da375bf585e4251816afc.zip
Adds a gtest_disable_pthreads CMake option; also fixes an include order problem in the cmake script.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 316d257d..130719fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,8 +1,5 @@
########################################################################
-# Experimental CMake build script for Google Test.
-#
-# Consider this a prototype. It will change drastically. For now,
-# this is only for people on the cutting edge.
+# CMake build script for Google Test.
#
# To run the tests for Google Test itself on Linux, use 'make test' or
# ctest. You can select which tests to run using 'ctest -R regex'.
@@ -23,6 +20,9 @@ option(gtest_build_tests "Build all of gtest's own tests." OFF)
option(gtest_build_samples "Build gtest's sample programs." OFF)
+option(gtest_disable_pthreads "Disable uses of pthreads in gtest." OFF)
+
+# Defines pre_project_set_up_hermetic_build() and set_up_hermetic_build().
include(cmake/hermetic_build.cmake OPTIONAL)
if (COMMAND pre_project_set_up_hermetic_build)
@@ -46,10 +46,10 @@ if (COMMAND set_up_hermetic_build)
set_up_hermetic_build()
endif()
-# Defines functions and variables used by Google Test.
+# Define helper functions and macros used by Google Test.
include(cmake/internal_utils.cmake)
-fix_default_settings() # Defined in internal_utils.cmake.
+config_compiler_and_linker() # Defined in internal_utils.cmake.
# Where Google Test's .h files can be found.
include_directories(