aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Woehlke <matthew.woehlke@kitware.com>2017-08-16 10:49:06 -0400
committerMatthew Woehlke <matthew.woehlke@kitware.com>2017-08-16 10:49:06 -0400
commit9469fb687d040b60c8749b7617fee4e77c7f6409 (patch)
tree3c943d237064d795df6f4b1dc021e797c0f643bc /CMakeLists.txt
parent5ed471caec6f341018707e74e0dc41201fb59edd (diff)
downloadgoogletest-9469fb687d040b60c8749b7617fee4e77c7f6409.tar.gz
googletest-9469fb687d040b60c8749b7617fee4e77c7f6409.tar.bz2
googletest-9469fb687d040b60c8749b7617fee4e77c7f6409.zip
Fix problem installing gtest when gmock enabled
Fix a bug deciding whether to enable the option to install Google Test caused by one of the dependent option dependencies not being defined yet. Fixes #1198; impossible to install Google Test if Google Mock is built.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96cdadef..f8a97faa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,10 +19,11 @@ else()
endif()
option(BUILD_GTEST "Builds the googletest subproject" OFF)
-cmake_dependent_option(INSTALL_GTEST "Enable installation of googletest. (Projects embedding googletest may want to turn this OFF.)" ON "BUILD_GTEST OR BUILD_GMOCK" OFF)
#Note that googlemock target already builds googletest
option(BUILD_GMOCK "Builds the googlemock subproject" ON)
+
+cmake_dependent_option(INSTALL_GTEST "Enable installation of googletest. (Projects embedding googletest may want to turn this OFF.)" ON "BUILD_GTEST OR BUILD_GMOCK" OFF)
cmake_dependent_option(INSTALL_GMOCK "Enable installation of googlemock. (Projects embedding googlemock may want to turn this OFF.)" ON "BUILD_GMOCK" OFF)
if(BUILD_GMOCK)