aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Grob <maetugr@gmail.com>2019-02-04 18:59:51 +0000
committerMatthias Grob <maetugr@gmail.com>2019-02-04 20:03:46 +0100
commit67265e07067758f51db6fd9296de02c16b1f9873 (patch)
tree9d36d216d741db43eca18f8444e6eeea070d4e2f /CMakeLists.txt
parent0ea2d8f8fa1601abb9ce713b7414e7b86f90bc61 (diff)
downloadgoogletest-67265e07067758f51db6fd9296de02c16b1f9873.tar.gz
googletest-67265e07067758f51db6fd9296de02c16b1f9873.tar.bz2
googletest-67265e07067758f51db6fd9296de02c16b1f9873.zip
cmake: move global project definition to beginning
such that necessary cmake variables to detect Cygwin are defined when setting the C++ standard and we can distinguish.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be14229e..c6775ef3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,8 @@
cmake_minimum_required(VERSION 2.8.8)
+project(googletest-distribution)
+set(GOOGLETEST_VERSION 1.9.0)
+
if (CMAKE_VERSION VERSION_LESS "3.1")
add_definitions(-std=c++11)
else()
@@ -12,9 +15,6 @@ if (POLICY CMP0048)
cmake_policy(SET CMP0048 NEW)
endif (POLICY CMP0048)
-project(googletest-distribution)
-set(GOOGLETEST_VERSION 1.9.0)
-
enable_testing()
include(CMakeDependentOption)