aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFábio Junqueira <fabio.blumm18@gmail.com>2015-11-11 18:29:41 -0200
committerFábio Junqueira <fabio.blumm18@gmail.com>2015-11-11 18:29:41 -0200
commit4a0b77ff7253a5aad78c6a798eefa1a7cb5da9c0 (patch)
treee0badcbf969e47a6053e00ab77df22576468fc35 /CMakeLists.txt
parent71a26ac68b28c61686b8941730a6b2577912e239 (diff)
downloadgoogletest-4a0b77ff7253a5aad78c6a798eefa1a7cb5da9c0.tar.gz
googletest-4a0b77ff7253a5aad78c6a798eefa1a7cb5da9c0.tar.bz2
googletest-4a0b77ff7253a5aad78c6a798eefa1a7cb5da9c0.zip
Create CMakeLists.txt
Adding functionality to build googletest from the root directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..8d2b552e
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 2.6.2)
+
+project( googletest-distribution )
+
+enable_testing()
+
+option(BUILD_GTEST "Builds the googletest subproject" OFF)
+
+#Note that googlemock target already builds googletest
+option(BUILD_GMOCK "Builds the googlemock subproject" ON)
+
+if(BUILD_GMOCK)
+ add_subdirectory( googlemock )
+elseif(BUILD_GTEST)
+ add_subdirectory( googletest )
+endif()