aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2010-03-26 05:35:42 +0000
committerzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2010-03-26 05:35:42 +0000
commit3569c3c86d520bd04ea806f84c9cb5aad0615fdf (patch)
treef9fcb5772dd668f165b69e502f9ca9886c920e27 /CMakeLists.txt
parent2429dfc6414762a692d3fbe02e8f00bbcba58c5e (diff)
downloadgoogletest-3569c3c86d520bd04ea806f84c9cb5aad0615fdf.tar.gz
googletest-3569c3c86d520bd04ea806f84c9cb5aad0615fdf.tar.bz2
googletest-3569c3c86d520bd04ea806f84c9cb5aad0615fdf.zip
Fixes compatibility with Visual Age versions lower than 9.0 (by Hady Zalek); updates the release notes.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8d18bd0..4c80bdef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,7 +88,10 @@ elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "SunPro")
elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "VisualAge")
set(cxx_exception_flags "-qeh")
set(cxx_no_exception_flags "-qnoeh")
- set(cxx_no_rtti_flags "-qnortti")
+ # Until version 9.0, Visual Age doesn't define a macro to indicate
+ # whether RTTI is enabled. Therefore we define GTEST_HAS_RTTI
+ # explicitly.
+ set(cxx_no_rtti_flags "-qnortti -DGTEST_HAS_RTTI=0")
endif()
if (CMAKE_USE_PTHREADS_INIT) # The pthreads library is available.