aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAbseil Team <absl-team@google.com>2020-02-12 15:41:54 -0500
committerMark Barolak <mbar@google.com>2020-02-13 13:52:14 -0500
commit23b2a3b1cf803999fb38175f6e9e038a4495c8a5 (patch)
tree36808413e5c92345d41551e3e70b85b3a605e638 /CMakeLists.txt
parent6f5fd0d7199b9a19faa9f499ecc266e6ae0329e7 (diff)
downloadgoogletest-23b2a3b1cf803999fb38175f6e9e038a4495c8a5.tar.gz
googletest-23b2a3b1cf803999fb38175f6e9e038a4495c8a5.tar.bz2
googletest-23b2a3b1cf803999fb38175f6e9e038a4495c8a5.zip
Googletest export
Remove the CMAKE_CXX_STANDARD from GoogleTest's CMakeLists.txt This causes ABI issues since it can create a mixed-mode build. The value should be inherited from the top-level build if it needs to be set. PiperOrigin-RevId: 294730724
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 755b8b72..d8834096 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,11 +10,7 @@ endif (POLICY CMP0048)
project(googletest-distribution)
set(GOOGLETEST_VERSION 1.10.0)
-if (CMAKE_VERSION VERSION_LESS "3.1")
- add_definitions(-std=c++11)
-else()
- set(CMAKE_CXX_STANDARD 11)
- set(CMAKE_CXX_STANDARD_REQUIRED ON)
+if (CMAKE_VERSION VERSION_GREATER_EQUAL "3.1")
if(NOT CYGWIN AND NOT MSYS)
set(CMAKE_CXX_EXTENSIONS OFF)
endif()