aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/subatomic
Commit message (Collapse)AuthorAgeFilesLines
* 2020 May 30 Breaking Changes Update (#9215)James Young2020-05-301-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Branch point for 2020 May 30 Breaking Change * Migrate `ACTION_LAYER_TOGGLE` to `TG()` (#8954) * Migrate `ACTION_MODS_ONESHOT` to `OSM()` (#8957) * Migrate `ACTION_DEFAULT_LAYER_SET` to `DF()` (#8958) * Migrate `ACTION_LAYER_MODS` to `LM()` (#8959) * Migrate `ACTION_MODS_TAP_KEY` to `MT()` (#8968) * Convert V-USB usbdrv to a submodule (#8321) * Unify Tap Hold functions and documentation (#8348) * Changing board names to prevent confusion (#8412) * Move the Keyboardio Model01 to a keyboardio/ subdir (#8499) * Move spaceman keyboards (#8830) * Migrate miscellaneous `fn_actions` entries (#8977) * Migrate `ACTION_MODS_KEY` to chained mod keycodes (#8979) * Organizing my keyboards (plaid, tartan, ergoinu) (#8537) * Refactor Lily58 to use split_common (#6260) * Refactor zinc to use split_common (#7114) * Add a message if bin/qmk doesn't work (#9000) * Fix conflicting types for 'tfp_printf' (#8269) * Fixed RGB_DISABLE_AFTER_TIMEOUT to be seconds based & small internals cleanup (#6480) * Refactor and updates to TKC1800 code (#8472) * Switch to qmk forks for everything (#9019) * audio refactor: replace deprecated PLAY_NOTE_ARRAY (#8484) * Audio enable corrections (2/3) (#8903) * Split HHKB to ANSI and JP layouts and Add VIA support for each (#8582) * Audio enable corrections (Part 4) (#8974) * Fix typo from PR7114 (#9171) * Augment future branch Changelogs (#8978) * Revert "Branch point for 2020 May 30 Breaking Change"
* Trim firmware sizes from default rules.mk, part 3 (#8045)ridingqwerty2020-01-301-4/+4
|
* [Keyboard] Subatomic refactor (#3194)noroadsleft2019-09-254-130/+462
| | | | | | | | | | | | | | | | | | | | | | | | * Refactor: matrix * New readme file * Configurator support * change info.json to debug linting * use an enum to manage the layers * readme cleanup file header, docs links * use #pragma once in keyboard header file * use new-style OLKB layout macro naming scheme * fix layout macro references in keymap.c * correct Keyboard Maintainer
* Cleanup rules.mk for USB64 and USB128 keyboards (#6769)fauxpark2019-09-191-46/+10
|
* Replace DEBOUNCING_DELAY (deprecated) with DEBOUNCE (#5997)Drashna Jaelre2019-06-061-1/+1
|
* Cleanup Default Keymaps (#5442)Drashna Jaelre2019-03-192-11/+3
| | | | | | | | * Cleanup Default Keymaps to conform to QMK Firmware standards * Minor fixes * Revert some changes
* Remove redundant KC_TRNS and KC_NO fillers in default keymaps (#5152)fauxpark2019-02-161-4/+0
|
* Adds a default value for IS_COMMAND for COMMAND feature (#4301)Drashna Jaelre2019-01-261-5/+0
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Add default value for IS_COMMAND for COMMAND feature * Cleanup and consistency * Update Templates to reflect change * Fix IS_COMMAND in template * Fix IS_COMMAND define * Use consistent IS_COMMAND block in templates * Remove unnecessary `#undef IS_COMMAND` directives * Fix compile issue on orthodox * Reomve IS_COMMAND option for newer boards * Remove all existing definitions of IS_COMMAND if they use default LSHIFT and RSHIFT setting * Remove a couple of additional IS_COMMAND defines * Remove remaining redundant IS_COMMAND definitions * Remove #undef IS_COMMAND from orthodox:drashna and whitefox:konstantin * Remove multiple empty lines in modified config.h files * Update additional boards * Reomve IS_COMMAND from newer boards * Update Alice keyboard * Remove IS_COMMAND from additional boards Jan 24th edition
* remove all makefiles from keyboard directoriesJack Humbert2017-09-271-0/+0
|
* adds subatomic files (non-working)Jack Humbert2017-08-206-67/+164
|
* Remove PLAY_NOTE_ARRAY usages to get rid of warning.Joe Wasson2017-08-201-6/+6
|
* Fix spelling of "persistent"Nikolaus Wittenstein2017-05-111-4/+4
| | | | Fixes #1201.
* Update existing keymapsGabriel Young2017-02-251-0/+29
| | | | | | Update existing keymaps to enable MIDI_BASIC functionality. Also added an option MIDI_ENABLE_STRICT to be strict about keycode use (which also reduces memory footprint at runtime)
* initial subatomic keymap (text)Jack Humbert2016-12-211-0/+280