aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/ckeys
Commit message (Collapse)AuthorAgeFilesLines
* Remove HD44780 References, Part 2 (#9918)James Young2020-08-072-29/+0
| | | | | * remove HD44780_ENABLE rules: C-F * remove HD44780_ENABLE config: C-F
* Change ?= to = in keyboard rules.mk (#9390)Ryan2020-06-151-13/+13
|
* 2020 May 30 Breaking Changes Update (#9215)James Young2020-05-302-4/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Branch point for 2020 May 30 Breaking Change * Migrate `ACTION_LAYER_TOGGLE` to `TG()` (#8954) * Migrate `ACTION_MODS_ONESHOT` to `OSM()` (#8957) * Migrate `ACTION_DEFAULT_LAYER_SET` to `DF()` (#8958) * Migrate `ACTION_LAYER_MODS` to `LM()` (#8959) * Migrate `ACTION_MODS_TAP_KEY` to `MT()` (#8968) * Convert V-USB usbdrv to a submodule (#8321) * Unify Tap Hold functions and documentation (#8348) * Changing board names to prevent confusion (#8412) * Move the Keyboardio Model01 to a keyboardio/ subdir (#8499) * Move spaceman keyboards (#8830) * Migrate miscellaneous `fn_actions` entries (#8977) * Migrate `ACTION_MODS_KEY` to chained mod keycodes (#8979) * Organizing my keyboards (plaid, tartan, ergoinu) (#8537) * Refactor Lily58 to use split_common (#6260) * Refactor zinc to use split_common (#7114) * Add a message if bin/qmk doesn't work (#9000) * Fix conflicting types for 'tfp_printf' (#8269) * Fixed RGB_DISABLE_AFTER_TIMEOUT to be seconds based & small internals cleanup (#6480) * Refactor and updates to TKC1800 code (#8472) * Switch to qmk forks for everything (#9019) * audio refactor: replace deprecated PLAY_NOTE_ARRAY (#8484) * Audio enable corrections (2/3) (#8903) * Split HHKB to ANSI and JP layouts and Add VIA support for each (#8582) * Audio enable corrections (Part 4) (#8974) * Fix typo from PR7114 (#9171) * Augment future branch Changelogs (#8978) * Revert "Branch point for 2020 May 30 Breaking Change"
* Remove no-longer-necessary LTO checks from keyboards' config.h files (#8773)Konstantin Đorđević2020-04-191-4/+3
| | | | | | | | | * Remove no-longer-necessary LTO checks from keyboards' config.h files * Remove unnecessary LTO check in @danielo515's Ergodox EZ keymap * Remove unnecessary USE_Link_Time_Optimization checks from keyboards' config.h files Note: DISABLE_LEADER doesn't seem to be used anywhere
* Updates cKeys/theDora README with explicit flashing instructions (#8016)Addison Cole2020-01-301-1/+9
| | | | | | | | | | | * adds to theDora readme for more explicit directions on flashing, with links and how to enter bootloader mode. * fmt * Corrects language of steps for loading firmware * Update keyboards/ckeys/thedora/readme.md
* Trim firmware sizes from default rules.mk, part 1 (#8027)ridingqwerty2020-01-293-13/+13
| | | | | | | | | | | * Removed reference to firmware size in 0-9,a-f board-level and default keymap 'rules.mk' files * Correct some 'rules.mk' in boards buried under vendor folders * PR8027 patch Co-authored-by: GeorgeKoenig <35542036+GeorgeKoenig@users.noreply.github.com> Co-authored-by: James Young <18669334+noroadsleft@users.noreply.github.com>
* Remove all references to "CUSTOM_MATRIX" as a diode direction (#7937)fauxpark2020-01-191-1/+1
|
* [Keyboard] Change cKeys Washington keyboard to use atmel-dfu bootloader (#7756)Benjamin Smith2020-01-011-2/+2
|
* [Keyboard] Add cKeys Washington keyboard (#7570)Benjamin Smith2019-12-099-0/+461
| | | | | | | | | | | | | | * Add cKeys Washington keyboard * Add suggested changes * Fix encoder direction * Remove unneeded file * Update config.h * Update washington.c
* Remove keymap_config extern from default keymaps (#7399)Drashna Jaelre2019-11-202-2/+0
| | | | | | | | | | * Remove keymap_config extern from default keymaps * Revert unicode Apparently VSCode does not like unicode, I didn't actually edit these lines, so it must have been automatic... :( Co-Authored-By: fauxpark <fauxpark@gmail.com>
* [Core] Cleanup rules.mk for F303 keyboards (#7306)fauxpark2019-11-141-0/+1
| | | | | | * Cleanup rules.mk for F303 keyboards * Fix small typo
* Cleanup rules.mk for 32U4 keyboards, A-F (#6804)fauxpark2019-10-053-134/+26
| | | | | | * Cleanup rules.mk for 32U4 keyboards, A-F * Put back stuff in VIA keymaps
* [Keyboard] cKeys theDora: Configurator fix (#6828)noroadsleft2019-09-271-5/+27
| | | Make the layout actually match the orientation.
* [Keyboard] Add cKeys' "The Dora" Board (#6469)Branden Byers2019-08-0610-2/+491
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Initial 4x5 * More board * Update exboard * Update * Change name to thedora * Update keyboards/ckeys/thedora/keymaps/default/keymap.c Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/ckeys/thedora/config.h Co-Authored-By: fauxpark <fauxpark@gmail.com> * Remove the slash * Attempt at fixing moxygen line break issues * Update keyboards/ckeys/thedora/config.h Co-Authored-By: fauxpark <fauxpark@gmail.com> * Add boilerplate * Update keyboards/ckeys/thedora/config.h Co-Authored-By: Drashna Jaelre <drashna@live.com>
* Remove commented out MCUs in rules.mk (#5884)fauxpark2019-07-163-3/+0
|
* Remove/migrate action_get_macro()s from default keymaps (#5625)fauxpark2019-07-151-15/+0
| | | | | | * Remove/migrate action_get_macro()s from default keymaps * Leave these breaks alone
* Replace DEBOUNCING_DELAY (deprecated) with DEBOUNCE (#5997)Drashna Jaelre2019-06-063-3/+3
|
* Cleanup Default Keymaps (#5442)Drashna Jaelre2019-03-192-8/+2
| | | | | | | | * Cleanup Default Keymaps to conform to QMK Firmware standards * Minor fixes * Revert some changes
* Remove CUSTOM_MATRIX option from diode direction (#5090)zvecr2019-02-183-3/+3
| | | | | | | | * Remove CUSTOM_MATRIX refs from DIODE_DIRECTION * Remove '#define DIODE_DIRECTION CUSTOM_MATRIX' * Remove CUSTOM_MATRIX refs from DIODE_DIRECTION documentation
* Adds a default value for IS_COMMAND for COMMAND feature (#4301)Drashna Jaelre2019-01-263-18/+0
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Add default value for IS_COMMAND for COMMAND feature * Cleanup and consistency * Update Templates to reflect change * Fix IS_COMMAND in template * Fix IS_COMMAND define * Use consistent IS_COMMAND block in templates * Remove unnecessary `#undef IS_COMMAND` directives * Fix compile issue on orthodox * Reomve IS_COMMAND option for newer boards * Remove all existing definitions of IS_COMMAND if they use default LSHIFT and RSHIFT setting * Remove a couple of additional IS_COMMAND defines * Remove remaining redundant IS_COMMAND definitions * Remove #undef IS_COMMAND from orthodox:drashna and whitefox:konstantin * Remove multiple empty lines in modified config.h files * Update additional boards * Reomve IS_COMMAND from newer boards * Update Alice keyboard * Remove IS_COMMAND from additional boards Jan 24th edition
* [Keyboard] Add cKeys Handwire 101 Keyboard (#4848)Branden Byers2019-01-1510-5/+679
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Update general README * Add handwire_101 * Update keyboards/ckeys/handwire_101/keymaps/default/keymap.c Co-Authored-By: brandenbyers <branden@brandenbyers.com> * Use Pragma once Co-Authored-By: brandenbyers <branden@brandenbyers.com> * Update keyboards/ckeys/handwire_101/config.h Co-Authored-By: brandenbyers <branden@brandenbyers.com> * Update keyboards/ckeys/handwire_101/config.h Co-Authored-By: brandenbyers <branden@brandenbyers.com> * Update keyboards/ckeys/handwire_101/handwire_101.h Co-Authored-By: brandenbyers <branden@brandenbyers.com> * Update keyboards/ckeys/handwire_101/handwire_101.h Co-Authored-By: brandenbyers <branden@brandenbyers.com> * Update keyboards/ckeys/handwire_101/keymaps/default/keymap.c Co-Authored-By: brandenbyers <branden@brandenbyers.com> * Update keyboards/ckeys/handwire_101/keymaps/default/keymap.c Co-Authored-By: brandenbyers <branden@brandenbyers.com> * Update keyboards/ckeys/handwire_101/keymaps/default/keymap.c Co-Authored-By: brandenbyers <branden@brandenbyers.com> * Update keyboards/ckeys/handwire_101/keymaps/default/keymap.c Co-Authored-By: brandenbyers <branden@brandenbyers.com> * Change KEYMAP to LAYOUT and remove endif * Apply suggestions from code review Co-Authored-By: brandenbyers <branden@brandenbyers.com> * Move layers to enum and remove KC_TRNS
* Modified URLs to point to new locationsJeremy Bernhardt2019-01-132-2/+2
|
* Remove empty fn_actions[]fauxpark2019-01-111-4/+0
|
* Keyboard: Ckeys refactor (#3681)noroadsleft2018-08-178-67/+81
| | | | | | | | | | | | | | | | | | | * Obelus Refactor: LAYOUT to LAYOUT_ortho_4x4 - Keymap also now uses #include QMK_KEYBOARD_H - Readability and white space changes - rules.mk now has LAYOUTS = ortho_4x4 - added info.json * naKey Refactor: LAYOUT to LAYOUT_numpad_5x4 - Matrix LAYOUT renamed to LAYOUT_numpad_5x4 - Now supports community layout numpad_5x4 - White space changes * naKey Configurator update Updated order of JSON objects to match new matrix order.
* Keyboard: Update KEYMAP to LAYOUT for ckeys obelus (#3495)MechMerlin2018-07-262-7/+7
|
* Move ckeys workshop to its own directory (#2928)MechMerlin2018-05-1017-0/+902
* move obelus and nakey to ckeys directory * delete the originals * short readme about ckeys * edit readmes to reflect new changes * add build guide info..and here's me trying to retrigger the build job