aboutsummaryrefslogtreecommitdiffstats
path: root/docs/keycodes.md
Commit message (Collapse)AuthorAgeFilesLines
* Issue 9942: Add LSA, RSA, RCS, LSA_T, RSA_T, and RCS_T (#9943)nopunin10did2020-08-171-34/+40
| | | | | | | | | | | | | | | | | | | | * Issue 9942: Add Quantum defines Add codes to quantum_keycodes for LSA, RSA, RCS, and their corresponding _T macros * 9942: Add documentation for new defines Add documentation for new defines in feature request 9942. Also define SAGR and SAGR_T as aliases for RSA and RSA_T. * Update quantum/quantum_keycodes.h * Update docs/keycodes.md * Update docs/keycodes.md * Update docs/keycodes.md * Update docs/keycodes.md
* Add OS compatibility matrix for basic keycodes (#8557)Ryan2020-06-091-199/+206
|
* One shot support for swap hands (#8590)Zsolt Parragi2020-05-141-0/+1
| | | | | | | | | | | | | | | | This commits add the SH_OS keycode, which works similarly to one shot layers: * while pressed, the keyboard is swapped * if no keys were pressed while it was pressed, the next key press is swapped SH_OS also supports chaining with one shot layers: OSL(x) + SH_OS + key interprets the key press on the oneshot layer. The ONESHOT_TIMEOUT setting used by one shot keys and layers is also used by oneshot swap hands. In the above chaining scenario the timeout of the oneshot layer is reset when swap hands is activated. Resolves #2682
* Add *OPT aliases for *ALT keycodes and macros (#8714)Konstantin Đorđević2020-04-121-6/+6
|
* Rename UC_OSX (and related constants) to UC_MAC (#8589)Konstantin Đorđević2020-03-311-1/+1
| | | | | | | | | | | | | | | | | | | | | * Rename UC_OSX (and related constants) to UC_MAC * Update UNICODE_SONG_OSX references to UNICODE_SONG_MAC * Update UC_M_OS references to UC_M_MA * Add UC_OSX alias for backwards compatibility * Add deprecation warning for UC_OSX to Unicode docs * Add UC_M_OS alias for backwards compatibility * Update newly found UC_M_OS and UNICODE_SONG_OSX references * Add legacy UNICODE_MODE_OSX alias, revert changes to user keymaps * Add legacy UNICODE_SONG_OSX alias, revert changes to user keymaps * Replace removed sounds in Unicode song doc examples
* [Docs] Update layer documentation (#8371)Drashna Jaelre2020-03-211-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | * [Docs] Update layer documentation * Add layer_state_cmp functions * Fix cut/copy/paste issue * Add id tags * Apply noroads corrections * Move Layers section to separate document * Fix ID tag for layers * Use better name for summary/side bar * Fix feature page linkage As well as a small spell error close by * Remove paper analogy for now
* keycodes.md: hard-code section link id attributesJames Young2020-03-051-22/+22
|
* keycodes.md: don't use section headings as linksJames Young2020-03-051-22/+66
| | | | It prevents the Table of Contents from parsing that heading.
* Add explicit id tags to externally linked headersskullY2020-03-051-4/+4
|
* remove some unnecessary external linksJames Young2020-03-051-2/+2
| | | | Also clean up some trailing whitespace.
* Move Grave Escape, Lock and Leader keycodes into their own sect… (#8093)fauxpark2020-02-071-9/+24
|
* Move Space Cadet keycodes to their own section in keycode reference (#7889)fauxpark2020-01-141-10/+12
|
* Add short aliases for Magic keycodes (#7541)fauxpark2019-12-051-31/+31
| | | | | | | | * Add short alias for `MAGIC_TOGGLE_NKRO` * Add aliases for the other Bootmagic keycodes * Replace long form in default keymaps
* Add shift-to-invert to remaining directional RGB_* keycode pairs (#7484)Manna Harbour2019-11-281-19/+19
| | | | | | | | | | | | | | | | | * Add shift-to-invert to remaining directional RGB_* keycode pairs RGB_MODE_FORWARD / RGB_MODE_REVERSE invert their functions when shift is held. This change adds the same capabilities to the remaining directional RGB_* keycode pairs. This improves consistency and provides full RGB control in a keymap containing only one keycode from each pair. * remove redundant variable * fix typo * Fix more typos Flyspell is on now I swear!
* [Core] Convert Dynamic Macro to a Core Feature (#5948)Drashna Jaelre2019-11-041-0/+10
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Convert Dynamic Macro to a Core Feature This imports the code from Dynamic Macro into the core code, and handles it, as such. This deprecates the old method but does not remove it, for legacy support. This way, no existing user files need to be touched. Additionally, this reorganizes the documentation to better reflect the changes. Also, it adds user hooks to the feature so users can customize the existing functionality. Based heavily on and closes #2976 * Apply suggestions from code review Co-Authored-By: fauxpark <fauxpark@gmail.com> Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Cleanup based on feedback * Add short-form keycodes and document them - add short-form keycodes to quantum/quantum_keycodes.h - document the new aliases in docs/feature_dynamic_macros.md * Add Dynamic Macros section and keycodes to docs/keycodes.md * Make anti-nesting optional * Add documentation for DYNAMIC_MACRO_NO_NESTING option * Fix Merge artifacts * Fix formatting typo in docs Co-Authored-By: James Young <18669334+noroadsleft@users.noreply.github.com> * Remove DYNAMIC_MACRO_RANGE as it's not needed * Fix includes and layer var type
* Remove obsolete note about media keys in MacOS (#6631)Steve Purcell2019-10-301-2/+2
| | | | | | | | | | | | | | * Remove obsolete note about media keys in MacOS KC_MNXT and KC_MPRV work fine on MacOS, so this note is obsolete. * Document behaviour of MEDIA_FAST_FORWARD/MEDIA_REWIND codes on MacOS * Small typo fix, and make OS-dependent keycode claim less absolute * Update docs/keycodes_basic.md Co-Authored-By: fauxpark <fauxpark@gmail.com>
* Backslash-escape pipe character in keycode lists (#7157)fauxpark2019-10-261-26/+26
|
* ARM split - Add bootmagic/magic keycodes for setting handedness (#6545)Joel Challis2019-09-241-28/+30
| | | | | | | | | | * Add docs on bootmagic/magic keycodes for setting handedness * Clang format fixes * Maintain backwards compatibility * Maintain backwards compatibility
* Added keycodes for swapping and unswapping the Control and OS keys (#6110)Stephen Wanhella2019-08-211-2/+9
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Add MAGIC_SWAP_CONTROL_LGUI and MAGIC_UNSWAP_CONTROL_LGUI keycodes Key codes to swap and unswap the control and windows/cmd keys * Fix issues with pull request #6110 Renamed swap/unswap lctl and lgui key codes, added key codes to swap/unswap rctl and rgui, and moved new bool inside keycode_config.h struct to the end * Move new keycodes to the end of the enum (#6110) * add cases for swapped control and OS keys to mod_config (#6110) * Add new keycodes to feature_bootmagic.md (#6110) * Add R+L swap codes to keep in parity with AG_* codes * Extend Magic range check to include new magic codes * Update audio docs * Combine 2 byte ranges into 1 word for EECONFG Fix names for Keymap config EEPROM * Update docs/feature_bootmagic.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update docs/feature_bootmagic.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update docs/feature_bootmagic.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update docs/feature_bootmagic.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com>
* [Docs] Reword confusing description of `TO(layer)` (#6174)lf2019-06-241-1/+1
| | | | | | | | * Reword confusing description of `TO(layer)` * Update docs/keycodes.md Co-Authored-By: Drashna Jaelre <drashna@live.com>
* Document MT keycode in keycodes.mdfauxpark2019-05-251-17/+18
|
* Added check for event pressed to clear space cadet (#5839)XScorpion22019-05-111-0/+5
| | | | | | | | | | | | * Added check for pressed to clear space cadet * Found some docs to update * Update docs/quantum_keycodes.md Co-Authored-By: fauxpark <fauxpark@gmail.com> * Changes from PR
* New keycode macro (XP) for shifted character pairs using UNICODEMAP + bug ↵Konstantin Đorđević2019-05-031-4/+12
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | fixes and improvements (#4803) * Expose unicode_saved_mods * Add UNICODEMAP shift pair functionality and XS keycode * Add XS to keycode reference documentation * Pick pair index based on both Shift and Caps Lock state * Add XS to Unicode feature docs * Clean up process_unicode* headers * Extract unicode_map index calculation into function * Pick pair index as XOR rather than OR of Shift and Caps states * unicode_input_start() has to be called before the unicode_map index is calculated * Replace unicodemap_input_error() with more generic unicode_input_cancel() * Replace register+tap+unregister with tap_code16(LCTL(LSFT(KC_U))) * UNICODE_OSX_KEY → UNICODE_KEY_OSX, UNICODE_WINC_KEY → UNICODE_KEY_WINC * Make keycode range checks more robust * Fix keycode range checks for different input modes * Add UNICODE_KEY_LNX, update docs * QK_UNICODEMAP_SHIFT → QK_UNICODEMAP_PAIR * XS → XP, update docs * Tweak Unicode docs * Use recently added MOD_MASK_SHIFT and IS_HOST_LED_ON helpers * Update Unicode table in docs/keycodes.md * Update Unicode docs per review comments * Replace references to Mac OS X with macOS in Unicode docs * As of v0.9.0, WinCompose supports all possible code points * Expand descriptions in XP docs * Update keycode table and cycling docs * Further expand cycling docs
* Add C(), A() and G() to match already existing S() (#4673)fauxpark2019-01-251-24/+24
|
* Adding documentation for the LM layer modifier. (#3617)Dave Brown2019-01-251-1/+1
| | | | | | | | | | | | * Adding documentation for the LM layer modifier. This will hopefully clear up some of the confusion around adding this layer modifier. I struggled with this a bit as well at first. * Removing duplicate table. * Changed section title to `Changing Layers` * Retain name
* Add new brightness aliases to keycodes_basic.mdfauxpark2019-01-171-203/+199
|
* MacOS Brightness Alias (#4836)Jeremy Bernhardt2019-01-171-4/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | * Added aliases for OSX brightness * Updated docs for alises * Moved aliases, added docs to Brightness section * Update docs/keycodes.md Co-Authored-By: germ <jeremythegeek@gmail.com> * Update docs/keycodes.md Co-Authored-By: germ <jeremythegeek@gmail.com> * Update keycode.h * Update keycode.h * Update keycodes.md * Update docs/keycodes.md Co-Authored-By: germ <jeremythegeek@gmail.com>
* Tidy up Mod-Tap shortcuts (#4806)fauxpark2019-01-081-17/+17
|
* Improve consistency in UNICODEMAP code and docs, update ↵Konstantin Đorđević2019-01-071-4/+4
| | | | | | | | | | | | | | | | | | | | | | | | | | | | docs/understanding_qmk (#4774) * Remove unused UNICODE(n) macro, update docs * Add note about max length of unicode_map to docs * QK_UNICODE_MAP → QK_UNICODEMAP * Refactor process_unicode_map * process_unicode_map → process_unicodemap This is done for consistency: UNICODEMAP is the method (hence UNICODEMAP_ENABLE, process_unicodemap), whereas unicode_map is the mapping table itself. * Update references and ordering in docs/understanding_qmk * Add additional note to docs/understanding_qmk * &unicode_map[index] → unicode_map + index This avoids the issue of the compiler sometimes complaining about the array index being out of range * Update docs/getting_started_make_guide * Update method sections in docs/feature_unicode
* Docs: Clarify audio keycodes (#4620)Drashna Jaelre2018-12-141-3/+3
| | | | | | | | | | | | | | | | * Clarify audio keycodes * Spelling errors Co-Authored-By: drashna <drashna@live.com> * Spacing in md Co-Authored-By: drashna <drashna@live.com> * Fix midi link too * Wordsmithing
* Docs: Remove duplicate layer block in keycodes.md (#4621)Drashna Jaelre2018-12-141-21/+10
| | | | | | | | | | * Docs: Remove duplicate layer block in keycodes.md Reorder and add OSL * remove glitch Co-Authored-By: drashna <drashna@live.com>
* Add standard definitions for ALGR and KC_ALGR (#4389)Konstantin Đorđević2018-12-121-2/+2
| | | | | | | | | | | | | | * Add standard ALGR defition, remove (re)definitions from language files * Use ALGR(kc) consistently in ALTGR(kc) aliases * Non-Nordic keymaps should not use NO_ALGR * Add standard KC_ALGR definition * Update docs with ALGR and KC_ALGR * Update SS_ALGR and ALGR_T aliases
* Add Extrakey support for Brightness up/down (#4477)Giuseppe Rota2018-11-281-0/+2
|
* Add EEPROM_RESET keycode to keycodes.md doc (#4473)noroadsleft2018-11-231-12/+13
|
* Fixed Unicode Support heading (#4425)James Osborn2018-11-141-0/+1
| | | Previously, Unicode Support heading appeared as the last row in the Swap Hands table.
* Docs: Fix descriptions of KC_INT1 and KC_INT3KOBAYASHI Daisuke2018-11-131-2/+2
|
* Remove ALTG(kc) as it's misleading and is not actually AltGr (#4338)Konstantin Đorđević2018-11-061-1/+0
| | | | | | * Remove ALTG(kc) as it's misleading and is not actually AltGr * Add temporary alias for ALGR in keyboards/planck/keymaps/pevecyan/keymap.c
* Create AG_TOGG code to toggle Alt/Gui swap.Joe Wasson2018-09-171-0/+1
|
* Docs: Tabulate Modifier & Mod-Tap keycode listings in advanced keycodes docs ↵fauxpark2018-08-301-2/+2
| | | | (#3799)
* Dedupe shifted keycodes listingfauxpark2018-08-111-1/+1
|
* More improvements to keycode docs (#3567)fauxpark2018-08-041-128/+141
| | | | | | * Reorder keycode list docs according to HID usage * Add missing keycodes/descriptions/aliases
* Docs: Fixed the link to the advanced keycodes wiki (#3505)Bruno Fagundez2018-07-261-1/+1
|
* Overhaul to keycode related docsDrashna Jaelre2018-07-151-87/+118
| | | | | | | | * Adds Audio Keycodes to both the feature page and master list * Re-orders the keycode list, so it's alphabetical (mostly) * Add additional (missing) sections to the keycode list * Add and update links in the keycode page * Add and reorder links in sidebar's keycode section
* Clean up SEND_STRING keycodes and add media keys (#3214)fauxpark2018-06-281-0/+1
| | | | | | | | | | * Clean up SEND_STRING keycodes and add media keys * Remove stray define * Add missing SEND_STRING keycodes for completeness Also, add KC_EJCT to the keycode references
* Add rgblight mode 35 (R,G,B test mode) (#3114)Takeshi ISHII2018-06-041-0/+1
| | | | | | | | * add rgblight mode 35 (RGB cyclic mode) into quantum/rgblight.c * Update docs, add rgblight mode 35(RGB cyclic) * rename RGBCYCLIC to RGBTEST
* Update documentation for rgb matrix (#3023)yiancar2018-05-221-0/+16
| | | | | | * Update documentation for rgb matrix - Updated keycodes.md to include RGB matrix keycodes + necessary link
* Add macro for momentarily switching to a layer while some mods are active ↵snyman2018-03-201-8/+9
| | | | | | | | | | | | | (#2460) * Macro for a momentary layer switch with mods Passes through to the existing ACTION_LAYER_MODS macro, albeit with more limited options due to lack of space in the quantum_keycodes enum. * Add documentation for LM layer-mod macro * Clean up Tap Toggle documentation
* Add CMD and WIN aliases for KC_GUI, GUI(kc), GUI_T(kc), etc.fauxpark2018-03-161-218/+218
|
* Add keycodes for swap-hands feature.Joe Wasson2018-03-161-0/+12
|
* Fixed typo of 'confid.h' to 'config.h' (#2448)Brian Choromanski2018-02-281-1/+1
| | | | | | * Fixed typo of 'confid.h' to 'config.h' * Fixed broken links in docs