aboutsummaryrefslogtreecommitdiffstats
path: root/os/rt/ports/e200/compilers/GCC
diff options
context:
space:
mode:
Diffstat (limited to 'os/rt/ports/e200/compilers/GCC')
-rw-r--r--os/rt/ports/e200/compilers/GCC/mk/port.mk8
-rw-r--r--os/rt/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk14
-rw-r--r--os/rt/ports/e200/compilers/GCC/mk/port_spc560bxx.mk14
-rw-r--r--os/rt/ports/e200/compilers/GCC/mk/port_spc560dxx.mk14
-rw-r--r--os/rt/ports/e200/compilers/GCC/mk/port_spc560pxx.mk14
-rw-r--r--os/rt/ports/e200/compilers/GCC/mk/port_spc563mxx.mk14
-rw-r--r--os/rt/ports/e200/compilers/GCC/mk/port_spc564axx.mk14
-rw-r--r--os/rt/ports/e200/compilers/GCC/mk/port_spc56ecxx.mk14
-rw-r--r--os/rt/ports/e200/compilers/GCC/mk/port_spc56elxx.mk14
-rw-r--r--os/rt/ports/e200/compilers/GCC/mk/port_spc57emxx.mk14
10 files changed, 8 insertions, 126 deletions
diff --git a/os/rt/ports/e200/compilers/GCC/mk/port.mk b/os/rt/ports/e200/compilers/GCC/mk/port.mk
new file mode 100644
index 000000000..04562c7d7
--- /dev/null
+++ b/os/rt/ports/e200/compilers/GCC/mk/port.mk
@@ -0,0 +1,8 @@
+# List of the ChibiOS/RT e200 generic port files.
+PORTSRC = $(CHIBIOS)/os/rt/ports/e200/chcore.c
+
+PORTASM = $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/ivor.s \
+ $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/chcoreasm.s
+
+PORTINC = $(CHIBIOS)/os/rt/ports/e200 \
+ $(CHIBIOS)/os/rt/ports/e200/compilers/GCC
diff --git a/os/rt/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk b/os/rt/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk
deleted file mode 100644
index cdd0b9c0e..000000000
--- a/os/rt/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-# List of the ChibiOS/RT e200z0 SPC560BCxx port files.
-PORTSRC = ${CHIBIOS}/os/rt/ports/e200/chcore.c
-
-PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560BCxx/boot.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
- $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/ivor.s
-
-PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
- ${CHIBIOS}/os/common/ports/e200/devices/SPC560BCxx \
- ${CHIBIOS}/os/rt/ports/e200 \
- ${CHIBIOS}/os/rt/ports/e200/compilers/GCC
-
-PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/rt/ports/e200/compilers/GCC/mk/port_spc560bxx.mk b/os/rt/ports/e200/compilers/GCC/mk/port_spc560bxx.mk
deleted file mode 100644
index c1b8447cf..000000000
--- a/os/rt/ports/e200/compilers/GCC/mk/port_spc560bxx.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-# List of the ChibiOS/RT e200z0 SPC560Bxx port files.
-PORTSRC = ${CHIBIOS}/os/rt/ports/e200/chcore.c
-
-PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560Bxx/boot.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
- $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/ivor.s
-
-PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
- ${CHIBIOS}/os/common/ports/e200/devices/SPC560Bxx \
- ${CHIBIOS}/os/rt/ports/e200 \
- ${CHIBIOS}/os/rt/ports/e200/compilers/GCC
-
-PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/rt/ports/e200/compilers/GCC/mk/port_spc560dxx.mk b/os/rt/ports/e200/compilers/GCC/mk/port_spc560dxx.mk
deleted file mode 100644
index 9959e375c..000000000
--- a/os/rt/ports/e200/compilers/GCC/mk/port_spc560dxx.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-# List of the ChibiOS/RT e200z0 SPC560Dxx port files.
-PORTSRC = ${CHIBIOS}/os/rt/ports/e200/chcore.c
-
-PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560Dxx/boot.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
- $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/ivor.s
-
-PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
- ${CHIBIOS}/os/common/ports/e200/devices/SPC560Dxx \
- ${CHIBIOS}/os/rt/ports/e200 \
- ${CHIBIOS}/os/rt/ports/e200/compilers/GCC
-
-PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/rt/ports/e200/compilers/GCC/mk/port_spc560pxx.mk b/os/rt/ports/e200/compilers/GCC/mk/port_spc560pxx.mk
deleted file mode 100644
index e9d078aff..000000000
--- a/os/rt/ports/e200/compilers/GCC/mk/port_spc560pxx.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-# List of the ChibiOS/RT e200z0 SPC560Pxx port files.
-PORTSRC = ${CHIBIOS}/os/rt/ports/e200/chcore.c
-
-PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560Pxx/boot.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
- $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/ivor.s
-
-PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
- ${CHIBIOS}/os/common/ports/e200/devices/SPC560Pxx \
- ${CHIBIOS}/os/rt/ports/e200 \
- ${CHIBIOS}/os/rt/ports/e200/compilers/GCC
-
-PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/rt/ports/e200/compilers/GCC/mk/port_spc563mxx.mk b/os/rt/ports/e200/compilers/GCC/mk/port_spc563mxx.mk
deleted file mode 100644
index 02b8069ad..000000000
--- a/os/rt/ports/e200/compilers/GCC/mk/port_spc563mxx.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-# List of the ChibiOS/RT e200z3 SPC563Mxx port files.
-PORTSRC = ${CHIBIOS}/os/rt/ports/e200/chcore.c
-
-PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC563Mxx/boot.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
- $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/ivor.s
-
-PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
- ${CHIBIOS}/os/common/ports/e200/devices/SPC563Mxx \
- ${CHIBIOS}/os/rt/ports/e200 \
- ${CHIBIOS}/os/rt/ports/e200/compilers/GCC
-
-PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/rt/ports/e200/compilers/GCC/mk/port_spc564axx.mk b/os/rt/ports/e200/compilers/GCC/mk/port_spc564axx.mk
deleted file mode 100644
index 8364e0ce8..000000000
--- a/os/rt/ports/e200/compilers/GCC/mk/port_spc564axx.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-# List of the ChibiOS/RT e200z4 SPC564Axx port files.
-PORTSRC = ${CHIBIOS}/os/rt/ports/e200/chcore.c
-
-PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC564Axx/boot.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
- $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/ivor.s
-
-PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
- ${CHIBIOS}/os/common/ports/e200/devices/SPC564Axx \
- ${CHIBIOS}/os/rt/ports/e200 \
- ${CHIBIOS}/os/rt/ports/e200/compilers/GCC
-
-PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/rt/ports/e200/compilers/GCC/mk/port_spc56ecxx.mk b/os/rt/ports/e200/compilers/GCC/mk/port_spc56ecxx.mk
deleted file mode 100644
index 4a951d1c2..000000000
--- a/os/rt/ports/e200/compilers/GCC/mk/port_spc56ecxx.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-# List of the ChibiOS/RT e200z4 SPC56ECxx port files.
-PORTSRC = ${CHIBIOS}/os/rt/ports/e200/chcore.c
-
-PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC56ECxx/boot.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
- $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/ivor.s
-
-PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
- ${CHIBIOS}/os/common/ports/e200/devices/SPC56ECxx \
- ${CHIBIOS}/os/rt/ports/e200 \
- ${CHIBIOS}/os/rt/ports/e200/compilers/GCC
-
-PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/rt/ports/e200/compilers/GCC/mk/port_spc56elxx.mk b/os/rt/ports/e200/compilers/GCC/mk/port_spc56elxx.mk
deleted file mode 100644
index adf2d5cb8..000000000
--- a/os/rt/ports/e200/compilers/GCC/mk/port_spc56elxx.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-# List of the ChibiOS/RT e200z4 SPC56ELxx port files.
-PORTSRC = ${CHIBIOS}/os/rt/ports/e200/chcore.c
-
-PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC56ELxx/boot.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
- $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/ivor.s
-
-PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
- ${CHIBIOS}/os/common/ports/e200/devices/SPC56ELxx \
- ${CHIBIOS}/os/rt/ports/e200 \
- ${CHIBIOS}/os/rt/ports/e200/compilers/GCC
-
-PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/rt/ports/e200/compilers/GCC/mk/port_spc57emxx.mk b/os/rt/ports/e200/compilers/GCC/mk/port_spc57emxx.mk
deleted file mode 100644
index 205dec659..000000000
--- a/os/rt/ports/e200/compilers/GCC/mk/port_spc57emxx.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-# List of the ChibiOS/RT e200z4 SPC57EMxx port files.
-PORTSRC = ${CHIBIOS}/os/rt/ports/e200/chcore.c
-
-PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC57EMxx/boot.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
- $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
- $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/ivor.s
-
-PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
- ${CHIBIOS}/os/common/ports/e200/devices/SPC57EMxx \
- ${CHIBIOS}/os/rt/ports/e200 \
- ${CHIBIOS}/os/rt/ports/e200/compilers/GCC
-
-PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld