aboutsummaryrefslogtreecommitdiffstats
path: root/os/rt/ports/e200/compilers/GCC/mk/port_spc560bxx.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/rt/ports/e200/compilers/GCC/mk/port_spc560bxx.mk')
-rw-r--r--os/rt/ports/e200/compilers/GCC/mk/port_spc560bxx.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/os/rt/ports/e200/compilers/GCC/mk/port_spc560bxx.mk b/os/rt/ports/e200/compilers/GCC/mk/port_spc560bxx.mk
new file mode 100644
index 000000000..c1b8447cf
--- /dev/null
+++ b/os/rt/ports/e200/compilers/GCC/mk/port_spc560bxx.mk
@@ -0,0 +1,14 @@
+# List of the ChibiOS/RT e200z0 SPC560Bxx port files.
+PORTSRC = ${CHIBIOS}/os/rt/ports/e200/chcore.c
+
+PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560Bxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
+ $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/ivor.s
+
+PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC560Bxx \
+ ${CHIBIOS}/os/rt/ports/e200 \
+ ${CHIBIOS}/os/rt/ports/e200/compilers/GCC
+
+PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld