aboutsummaryrefslogtreecommitdiffstats
path: root/os/rt/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/rt/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk')
-rw-r--r--os/rt/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/os/rt/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk b/os/rt/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk
new file mode 100644
index 000000000..cdd0b9c0e
--- /dev/null
+++ b/os/rt/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk
@@ -0,0 +1,14 @@
+# List of the ChibiOS/RT e200z0 SPC560BCxx port files.
+PORTSRC = ${CHIBIOS}/os/rt/ports/e200/chcore.c
+
+PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560BCxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
+ $(CHIBIOS)/os/rt/ports/e200/compilers/GCC/ivor.s
+
+PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC560BCxx \
+ ${CHIBIOS}/os/rt/ports/e200 \
+ ${CHIBIOS}/os/rt/ports/e200/compilers/GCC
+
+PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld