aboutsummaryrefslogtreecommitdiffstats
path: root/os/rt/ports/ARMCMx/compilers/GCC/mk/port_stm32l1xx.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/rt/ports/ARMCMx/compilers/GCC/mk/port_stm32l1xx.mk')
-rw-r--r--os/rt/ports/ARMCMx/compilers/GCC/mk/port_stm32l1xx.mk13
1 files changed, 6 insertions, 7 deletions
diff --git a/os/rt/ports/ARMCMx/compilers/GCC/mk/port_stm32l1xx.mk b/os/rt/ports/ARMCMx/compilers/GCC/mk/port_stm32l1xx.mk
index c6635eaad..3ae4ffed3 100644
--- a/os/rt/ports/ARMCMx/compilers/GCC/mk/port_stm32l1xx.mk
+++ b/os/rt/ports/ARMCMx/compilers/GCC/mk/port_stm32l1xx.mk
@@ -1,16 +1,15 @@
# List of the ChibiOS/RT Cortex-M3 STM32L1xx port files.
-PORTSRC = $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/crt0.c \
- $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/vectors.c \
+include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32l1xx.mk
+
+PORTSRC = $(STARTUPSRC) \
$(CHIBIOS)/os/rt/ports/ARMCMx/chcore.c \
$(CHIBIOS)/os/rt/ports/ARMCMx/chcore_v7m.c
-PORTASM = $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/crt0_v7m.s \
+PORTASM = $(STARTUPASM) \
$(CHIBIOS)/os/rt/ports/ARMCMx/compilers/GCC/chcoreasm_v7m.s
-PORTINC = $(CHIBIOS)/os/ext/CMSIS/include \
- $(CHIBIOS)/os/ext/CMSIS/ST \
- $(CHIBIOS)/os/common/ports/ARMCMx/devices/STM32L1xx \
+PORTINC = $(STARTUPINC) \
$(CHIBIOS)/os/rt/ports/ARMCMx \
$(CHIBIOS)/os/rt/ports/ARMCMx/compilers/GCC
-PORTLD = $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/ld
+PORTLD = $(STARTUPLD)