aboutsummaryrefslogtreecommitdiffstats
path: root/os/ports/GCC
diff options
context:
space:
mode:
Diffstat (limited to 'os/ports/GCC')
-rw-r--r--os/ports/GCC/ARMCMx/chcore_v6m.c2
-rw-r--r--os/ports/GCC/ARMCMx/chcore_v7m.c2
-rw-r--r--os/ports/GCC/PPC/rules.mk3
3 files changed, 5 insertions, 2 deletions
diff --git a/os/ports/GCC/ARMCMx/chcore_v6m.c b/os/ports/GCC/ARMCMx/chcore_v6m.c
index 63576cb3d..6bdbbfeb5 100644
--- a/os/ports/GCC/ARMCMx/chcore_v6m.c
+++ b/os/ports/GCC/ARMCMx/chcore_v6m.c
@@ -118,7 +118,7 @@ void _port_irq_epilogue(regarm_t lr) {
}
/* Note, returning without unlocking is intentional, this is done in
- order to keep the rest of the context switching atomic.*/
+ order to keep the rest of the context switch atomic.*/
}
}
diff --git a/os/ports/GCC/ARMCMx/chcore_v7m.c b/os/ports/GCC/ARMCMx/chcore_v7m.c
index d621074f1..08f3fbba1 100644
--- a/os/ports/GCC/ARMCMx/chcore_v7m.c
+++ b/os/ports/GCC/ARMCMx/chcore_v7m.c
@@ -184,7 +184,7 @@ void _port_irq_epilogue(void) {
#endif
/* Note, returning without unlocking is intentional, this is done in
- order to keep the rest of the context switching atomic.*/
+ order to keep the rest of the context switch atomic.*/
return;
}
port_unlock_from_isr();
diff --git a/os/ports/GCC/PPC/rules.mk b/os/ports/GCC/PPC/rules.mk
index 6b49e736a..75f4bf8c8 100644
--- a/os/ports/GCC/PPC/rules.mk
+++ b/os/ports/GCC/PPC/rules.mk
@@ -23,6 +23,9 @@ ifeq ($(USE_VLE),yes)
DDEFS += -DPPC_USE_VLE=1
DADEFS += -DPPC_USE_VLE=1
MCU += -mvle
+else
+ DDEFS += -DPPC_USE_VLE=0
+ DADEFS += -DPPC_USE_VLE=0
endif
# Source files groups and paths