aboutsummaryrefslogtreecommitdiffstats
path: root/os/ports/GCC/ARMCMx/STM32F4xx/port.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/ports/GCC/ARMCMx/STM32F4xx/port.mk')
-rw-r--r--os/ports/GCC/ARMCMx/STM32F4xx/port.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/os/ports/GCC/ARMCMx/STM32F4xx/port.mk b/os/ports/GCC/ARMCMx/STM32F4xx/port.mk
new file mode 100644
index 000000000..072e2d363
--- /dev/null
+++ b/os/ports/GCC/ARMCMx/STM32F4xx/port.mk
@@ -0,0 +1,14 @@
+# List of the ChibiOS/RT Cortex-M3 STM32 port files.
+PORTSRC = $(CHIBIOS)/os/ports/GCC/ARMCMx/crt0.c \
+ $(CHIBIOS)/os/ports/GCC/ARMCMx/STM32F4xx/vectors.c \
+ ${CHIBIOS}/os/ports/GCC/ARMCMx/chcore.c \
+ ${CHIBIOS}/os/ports/GCC/ARMCMx/chcore_v7m.c \
+ ${CHIBIOS}/os/ports/GCC/ARMCMx/nvic.c
+
+PORTASM =
+
+PORTINC = ${CHIBIOS}/os/ports/common/ARMCMx/CMSIS/include \
+ ${CHIBIOS}/os/ports/GCC/ARMCMx \
+ ${CHIBIOS}/os/ports/GCC/ARMCMx/STM32F4xx
+
+PORTLD = ${CHIBIOS}/os/ports/GCC/ARMCMx/STM32F4xx/ld