aboutsummaryrefslogtreecommitdiffstats
path: root/os/ports/GCC/ARMCMx/STM32F3xx/port.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/ports/GCC/ARMCMx/STM32F3xx/port.mk')
-rw-r--r--os/ports/GCC/ARMCMx/STM32F3xx/port.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/os/ports/GCC/ARMCMx/STM32F3xx/port.mk b/os/ports/GCC/ARMCMx/STM32F3xx/port.mk
new file mode 100644
index 000000000..09cc8dfd6
--- /dev/null
+++ b/os/ports/GCC/ARMCMx/STM32F3xx/port.mk
@@ -0,0 +1,15 @@
+# List of the ChibiOS/RT Cortex-M4 STM32 port files.
+PORTSRC = $(CHIBIOS)/os/ports/GCC/ARMCMx/crt0.c \
+ $(CHIBIOS)/os/ports/GCC/ARMCMx/STM32F3xx/vectors.c \
+ ${CHIBIOS}/os/ports/GCC/ARMCMx/chcore.c \
+ ${CHIBIOS}/os/ports/GCC/ARMCMx/chcore_v7m.c \
+ ${CHIBIOS}/os/ports/common/ARMCMx/nvic.c
+
+PORTASM =
+
+PORTINC = ${CHIBIOS}/os/ports/common/ARMCMx/CMSIS/include \
+ ${CHIBIOS}/os/ports/common/ARMCMx \
+ ${CHIBIOS}/os/ports/GCC/ARMCMx \
+ ${CHIBIOS}/os/ports/GCC/ARMCMx/STM32F3xx
+
+PORTLD = ${CHIBIOS}/os/ports/GCC/ARMCMx/STM32F3xx/ld