aboutsummaryrefslogtreecommitdiffstats
path: root/os/ports/GCC/ARM/LPC214x/port.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/ports/GCC/ARM/LPC214x/port.mk')
-rw-r--r--os/ports/GCC/ARM/LPC214x/port.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/os/ports/GCC/ARM/LPC214x/port.mk b/os/ports/GCC/ARM/LPC214x/port.mk
new file mode 100644
index 000000000..1fcd858e5
--- /dev/null
+++ b/os/ports/GCC/ARM/LPC214x/port.mk
@@ -0,0 +1,13 @@
+# List of the ChibiOS/RT ARM7 LPC214x port files.
+PORTSRC = ${CHIBIOS}/os/ports/GCC/ARM/chcore.c
+
+PORTASM = ${CHIBIOS}/os/ports/GCC/ARM/crt0.s \
+ ${CHIBIOS}/os/ports/GCC/ARM/chcoreasm.s \
+ ${CHIBIOS}/os/ports/GCC/ARM/LPC214x/vectors.s
+
+
+PORTINC = ${CHIBIOS}/os/ports/GCC/ARM \
+ ${CHIBIOS}/os/ports/GCC/ARM/LPC214x
+
+PORTLD = ${CHIBIOS}/os/ports/GCC/ARM/LPC214x/ld
+