aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F4xx/platform.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal/ports/STM32/STM32F4xx/platform.mk')
-rw-r--r--os/hal/ports/STM32/STM32F4xx/platform.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/os/hal/ports/STM32/STM32F4xx/platform.mk b/os/hal/ports/STM32/STM32F4xx/platform.mk
index f2547b018..ee04c8c00 100644
--- a/os/hal/ports/STM32/STM32F4xx/platform.mk
+++ b/os/hal/ports/STM32/STM32F4xx/platform.mk
@@ -58,6 +58,9 @@ endif
ifneq ($(findstring HAL_USE_UART TRUE,$(HALCONF)),)
PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/uart_lld.c
endif
+ifneq ($(findstring HAL_USE_WDG TRUE,$(HALCONF)),)
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/xWDGv1/wdg_lld.c
+endif
else
PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32F4xx/hal_lld.c \
@@ -80,7 +83,8 @@ PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/pwm_lld.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/st_lld.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/serial_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/uart_lld.c
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/uart_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/xWDGv1/wdg_lld.c
endif
# Required include directories
@@ -99,4 +103,5 @@ PLATFORMINC := $(CHIBIOS)/os/hal/ports/common/ARMCMx \
$(CHIBIOS)/os/hal/ports/STM32/LLD/SDIOv1 \
$(CHIBIOS)/os/hal/ports/STM32/LLD/SPIv1 \
$(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1 \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1 \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/xWDGv1