aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F37x/platform.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal/ports/STM32/STM32F37x/platform.mk')
-rw-r--r--os/hal/ports/STM32/STM32F37x/platform.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/os/hal/ports/STM32/STM32F37x/platform.mk b/os/hal/ports/STM32/STM32F37x/platform.mk
index 9dbccae60..d5de03020 100644
--- a/os/hal/ports/STM32/STM32F37x/platform.mk
+++ b/os/hal/ports/STM32/STM32F37x/platform.mk
@@ -1,5 +1,6 @@
# Required platform files.
PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
+ $(CHIBIOS)/os/hal/ports/STM32/STM32F37x/stm32_isr.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32F37x/hal_lld.c
# Required include directories.
@@ -19,12 +20,8 @@ HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h | egrep -e "\#define"))
ifneq ($(findstring HAL_USE_ADC TRUE,$(HALCONF)),)
PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32F37x/hal_adc_lld.c
endif
-ifneq ($(findstring HAL_USE_EXT TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32F37x/hal_ext_lld_isr.c
-endif
else
PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32F37x/hal_adc_lld.c
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32F37x/hal_ext_lld_isr.c
endif
# Drivers compatible with the platform.