aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk')
-rw-r--r--os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk9
1 files changed, 7 insertions, 2 deletions
diff --git a/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk b/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
index ddf8a2156..38fec9817 100644
--- a/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
+++ b/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
@@ -55,6 +55,9 @@ endif
ifneq ($(findstring HAL_USE_UART TRUE,$(HALCONF)),)
PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/uart_lld.c
endif
+ifneq ($(findstring HAL_USE_WDG TRUE,$(HALCONF)),)
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/xWDGv1/wdg_lld.c
+endif
else
PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/hal_lld.c \
@@ -76,7 +79,8 @@ PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/pwm_lld.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/st_lld.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/serial_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/uart_lld.c
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/uart_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/xWDGv1/wdg_lld.c
endif
# Required include directories
@@ -93,4 +97,5 @@ PLATFORMINC := $(CHIBIOS)/os/hal/ports/common/ARMCMx \
$(CHIBIOS)/os/hal/ports/STM32/LLD/SDIOv1 \
$(CHIBIOS)/os/hal/ports/STM32/LLD/SPIv1 \
$(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1 \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1 \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/xWDGv1