aboutsummaryrefslogtreecommitdiffstats
path: root/os/common/ports/ARM/compilers/GCC
diff options
context:
space:
mode:
Diffstat (limited to 'os/common/ports/ARM/compilers/GCC')
-rw-r--r--os/common/ports/ARM/compilers/GCC/rules.mk13
1 files changed, 12 insertions, 1 deletions
diff --git a/os/common/ports/ARM/compilers/GCC/rules.mk b/os/common/ports/ARM/compilers/GCC/rules.mk
index 0b86f54de..2a5bdb8a4 100644
--- a/os/common/ports/ARM/compilers/GCC/rules.mk
+++ b/os/common/ports/ARM/compilers/GCC/rules.mk
@@ -77,7 +77,9 @@ ifeq ($(BUILDDIR),.)
BUILDDIR = build
endif
OUTFILES = $(BUILDDIR)/$(PROJECT).elf $(BUILDDIR)/$(PROJECT).hex \
- $(BUILDDIR)/$(PROJECT).bin $(BUILDDIR)/$(PROJECT).dmp
+ $(BUILDDIR)/$(PROJECT).bin $(BUILDDIR)/$(PROJECT).dmp \
+ $(BUILDDIR)/$(PROJECT).list
+
# Source files groups and paths
ifeq ($(USE_THUMB),yes)
@@ -268,6 +270,15 @@ else
@echo Done
endif
+%.list: %.elf $(LDSCRIPT)
+ifeq ($(USE_VERBOSE_COMPILE),yes)
+ $(OD) -S $< > $@
+else
+ @echo Creating $@
+ @$(OD) -S $< > $@
+ @echo Done
+endif
+
lib: $(OBJS) $(BUILDDIR)/lib$(PROJECT).a
$(BUILDDIR)/lib$(PROJECT).a: $(OBJS)