aboutsummaryrefslogtreecommitdiffstats
path: root/os/ports/GCC/ARMCMx
diff options
context:
space:
mode:
authorgdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2011-08-07 16:42:24 +0000
committergdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2011-08-07 16:42:24 +0000
commit02f5682694bf8259edfd9159c712086ffde1bf33 (patch)
treee6b5a43e48aca541640edbca6c1c566de6f58404 /os/ports/GCC/ARMCMx
parenta2e8b0a34abc3133df25b36fceacfa4e664c6e01 (diff)
downloadChibiOS-02f5682694bf8259edfd9159c712086ffde1bf33.tar.gz
ChibiOS-02f5682694bf8259edfd9159c712086ffde1bf33.tar.bz2
ChibiOS-02f5682694bf8259edfd9159c712086ffde1bf33.zip
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@3206 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/ports/GCC/ARMCMx')
-rw-r--r--os/ports/GCC/ARMCMx/STM32F1xx/cmparams.h8
-rw-r--r--os/ports/GCC/ARMCMx/STM32F1xx/port.mk6
-rw-r--r--os/ports/GCC/ARMCMx/STM32F1xx/vectors.c8
3 files changed, 11 insertions, 11 deletions
diff --git a/os/ports/GCC/ARMCMx/STM32F1xx/cmparams.h b/os/ports/GCC/ARMCMx/STM32F1xx/cmparams.h
index 5b630dbb8..02d07e73d 100644
--- a/os/ports/GCC/ARMCMx/STM32F1xx/cmparams.h
+++ b/os/ports/GCC/ARMCMx/STM32F1xx/cmparams.h
@@ -19,13 +19,13 @@
*/
/**
- * @file GCC/ARMCMx/STM32/cmparams.h
- * @brief ARM Cortex-M3 parameters for the STM32.
+ * @file GCC/ARMCMx/STM32F1xx/cmparams.h
+ * @brief ARM Cortex-M3 parameters for the STM32F1xx.
*
- * @defgroup ARMCMx_STM32 STM32 Specific Parameters
+ * @defgroup ARMCMx_STM32F1xx STM32F1xx Specific Parameters
* @ingroup ARMCMx_SPECIFIC
* @details This file contains the Cortex-M3 specific parameters for the
- * STM32 platform.
+ * STM32F1xx platform.
* @{
*/
diff --git a/os/ports/GCC/ARMCMx/STM32F1xx/port.mk b/os/ports/GCC/ARMCMx/STM32F1xx/port.mk
index 9646c1d6f..6e0e16902 100644
--- a/os/ports/GCC/ARMCMx/STM32F1xx/port.mk
+++ b/os/ports/GCC/ARMCMx/STM32F1xx/port.mk
@@ -1,6 +1,6 @@
# List of the ChibiOS/RT Cortex-M3 STM32 port files.
PORTSRC = $(CHIBIOS)/os/ports/GCC/ARMCMx/crt0.c \
- $(CHIBIOS)/os/ports/GCC/ARMCMx/STM32/vectors.c \
+ $(CHIBIOS)/os/ports/GCC/ARMCMx/STM32F1xx/vectors.c \
${CHIBIOS}/os/ports/GCC/ARMCMx/chcore.c \
${CHIBIOS}/os/ports/GCC/ARMCMx/chcore_v7m.c \
${CHIBIOS}/os/ports/GCC/ARMCMx/nvic.c
@@ -8,6 +8,6 @@ PORTSRC = $(CHIBIOS)/os/ports/GCC/ARMCMx/crt0.c \
PORTASM =
PORTINC = ${CHIBIOS}/os/ports/GCC/ARMCMx \
- ${CHIBIOS}/os/ports/GCC/ARMCMx/STM32
+ ${CHIBIOS}/os/ports/GCC/ARMCMx/STM32F1xx
-PORTLD = ${CHIBIOS}/os/ports/GCC/ARMCMx/STM32/ld
+PORTLD = ${CHIBIOS}/os/ports/GCC/ARMCMx/STM32F1xx/ld
diff --git a/os/ports/GCC/ARMCMx/STM32F1xx/vectors.c b/os/ports/GCC/ARMCMx/STM32F1xx/vectors.c
index e4d1bcb28..d47eeb72e 100644
--- a/os/ports/GCC/ARMCMx/STM32F1xx/vectors.c
+++ b/os/ports/GCC/ARMCMx/STM32F1xx/vectors.c
@@ -19,12 +19,12 @@
*/
/**
- * @file GCC/ARMCMx/STM32/vectors.c
- * @brief Interrupt vectors for the STM32 family.
+ * @file GCC/ARMCMx/STM32F1xx/vectors.c
+ * @brief Interrupt vectors for the STM32F1xx family.
*
- * @defgroup ARMCMx_STM32_VECTORS STM32 Interrupt Vectors
+ * @defgroup ARMCMx_STM32F1xx_VECTORS STM32F1xx Interrupt Vectors
* @ingroup ARMCMx_SPECIFIC
- * @details Interrupt vectors for the STM32 family.
+ * @details Interrupt vectors for the STM32F1xx family.
* @{
*/