aboutsummaryrefslogtreecommitdiffstats
path: root/os/ports/GCC/ARMCMx/LPC11xx
diff options
context:
space:
mode:
authorgdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2010-11-06 10:02:07 +0000
committergdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2010-11-06 10:02:07 +0000
commitc922ada20f99517c4cb98118b954c9b1182fce2c (patch)
treeb537b381672e5db95b6fe09262de7eb3cc9c30c3 /os/ports/GCC/ARMCMx/LPC11xx
parent985c794c0c8e74fef8ddc845c9a1a680b5c23f4f (diff)
downloadChibiOS-c922ada20f99517c4cb98118b954c9b1182fce2c.tar.gz
ChibiOS-c922ada20f99517c4cb98118b954c9b1182fce2c.tar.bz2
ChibiOS-c922ada20f99517c4cb98118b954c9b1182fce2c.zip
Changes to the various Cortex vector tables.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@2328 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/ports/GCC/ARMCMx/LPC11xx')
-rw-r--r--os/ports/GCC/ARMCMx/LPC11xx/port.mk2
-rw-r--r--os/ports/GCC/ARMCMx/LPC11xx/vectors.s18
2 files changed, 18 insertions, 2 deletions
diff --git a/os/ports/GCC/ARMCMx/LPC11xx/port.mk b/os/ports/GCC/ARMCMx/LPC11xx/port.mk
index dba1defc8..f8411ddf8 100644
--- a/os/ports/GCC/ARMCMx/LPC11xx/port.mk
+++ b/os/ports/GCC/ARMCMx/LPC11xx/port.mk
@@ -4,7 +4,7 @@ PORTSRC = ${CHIBIOS}/os/ports/GCC/ARMCMx/chcore.c \
${CHIBIOS}/os/ports/GCC/ARMCMx/nvic.c \
${CHIBIOS}/os/ports/GCC/ARMCMx/cmsis/core_cm0.c
-PORTASM = ${CHIBIOS}/os/ports/GCC/ARMCMx/crt0.s
+PORTASM = ${CHIBIOS}/os/ports/GCC/ARMCMx/crt0_v6m.s
PORTINC = ${CHIBIOS}/os/ports/GCC/ARMCMx \
${CHIBIOS}/os/ports/GCC/ARMCMx/LPC11xx \
diff --git a/os/ports/GCC/ARMCMx/LPC11xx/vectors.s b/os/ports/GCC/ARMCMx/LPC11xx/vectors.s
index 44ea654ce..3f44c900f 100644
--- a/os/ports/GCC/ARMCMx/LPC11xx/vectors.s
+++ b/os/ports/GCC/ARMCMx/LPC11xx/vectors.s
@@ -17,6 +17,16 @@
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
+/**
+ * @file LPC11xx/vectors.s
+ * @brief Interrupt vectors for the LPC11xx family.
+ *
+ * @addtogroup ARMCMx_CORE
+ * @{
+ */
+
+#if !defined(__DOXYGEN__)
+
.syntax unified
.thumb
@@ -209,4 +219,10 @@ VectorB8:
.weak VectorBC
VectorBC:
-here: b here
+ .global _unhandled_exception
+_unhandled_exception:
+ b _unhandled_exception
+
+#endif
+
+/** @} */