aboutsummaryrefslogtreecommitdiffstats
path: root/os/ports/GCC/ARMCMx/LPC11xx
diff options
context:
space:
mode:
authorgdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2010-04-02 10:27:19 +0000
committergdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2010-04-02 10:27:19 +0000
commit28c7188ba7f07530b10332ab9ba5c435880b26af (patch)
treeb30a0476aca0400803fe7e3ad45b81843546b73b /os/ports/GCC/ARMCMx/LPC11xx
parent11944e2f3d3cdd244e7b824f6305a257453d8369 (diff)
downloadChibiOS-28c7188ba7f07530b10332ab9ba5c435880b26af.tar.gz
ChibiOS-28c7188ba7f07530b10332ab9ba5c435880b26af.tar.bz2
ChibiOS-28c7188ba7f07530b10332ab9ba5c435880b26af.zip
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@1829 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/ports/GCC/ARMCMx/LPC11xx')
-rw-r--r--os/ports/GCC/ARMCMx/LPC11xx/cmparams.h56
-rw-r--r--os/ports/GCC/ARMCMx/LPC11xx/port.mk11
-rw-r--r--os/ports/GCC/ARMCMx/LPC11xx/vectors.s212
3 files changed, 0 insertions, 279 deletions
diff --git a/os/ports/GCC/ARMCMx/LPC11xx/cmparams.h b/os/ports/GCC/ARMCMx/LPC11xx/cmparams.h
deleted file mode 100644
index 33de7b0f8..000000000
--- a/os/ports/GCC/ARMCMx/LPC11xx/cmparams.h
+++ /dev/null
@@ -1,56 +0,0 @@
-/*
- ChibiOS/RT - Copyright (C) 2006,2007,2008,2009,2010 Giovanni Di Sirio.
-
- This file is part of ChibiOS/RT.
-
- ChibiOS/RT is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 3 of the License, or
- (at your option) any later version.
-
- ChibiOS/RT is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-/**
- * @file ARMCMx/LPC111x/cmparams.h
- * @brief ARM Cortex-M0 LPC111x specific parameters.
- *
- * @defgroup ARMCMx_LPC111x LPC111x specific parameters
- * @ingroup ARMCMx
- * @details This file contains the Cortex-M0 specific parameters for the
- * LPC111x platform.
- * @{
- */
-
-#ifndef _CMPARAMS_H_
-#define _CMPARAMS_H_
-
-/**
- * @brief Cortex core model.
- */
-#define CORTEX_MODEL CORTEX_M0
-
-/**
- * @brief Systick unit presence.
- */
-#define CORTEX_HAS_ST TRUE
-
-/**
- * @brief Memory Protection unit presence.
- */
-#define CORTEX_HAS_MPU FALSE
-
-/**
- * @brief Number of bits in priority masks.
- */
-#define CORTEX_PRIORITY_BITS 2
-
-#endif /* _CMPARAMS_H_ */
-
-/** @} */
diff --git a/os/ports/GCC/ARMCMx/LPC11xx/port.mk b/os/ports/GCC/ARMCMx/LPC11xx/port.mk
deleted file mode 100644
index 3935b9195..000000000
--- a/os/ports/GCC/ARMCMx/LPC11xx/port.mk
+++ /dev/null
@@ -1,11 +0,0 @@
-# List of the ChibiOS/RT Cortex-M0 LPC111x port files.
-PORTSRC = ${CHIBIOS}/os/ports/GCC/ARMCMx/chcore.c \
- ${CHIBIOS}/os/ports/GCC/ARMCMx/chcore_v6m.c \
- ${CHIBIOS}/os/ports/GCC/ARMCMx/nvic.c \
- ${CHIBIOS}/os/ports/GCC/ARMCMx/cmsis/core_cm0.c
-
-PORTASM = ${CHIBIOS}/os/ports/GCC/ARMCMx/crt0.s
-
-PORTINC = ${CHIBIOS}/os/ports/GCC/ARMCMx \
- ${CHIBIOS}/os/ports/GCC/ARMCMx/LPC11xx \
- ${CHIBIOS}/os/ports/GCC/ARMCMx/cmsis
diff --git a/os/ports/GCC/ARMCMx/LPC11xx/vectors.s b/os/ports/GCC/ARMCMx/LPC11xx/vectors.s
deleted file mode 100644
index 44ea654ce..000000000
--- a/os/ports/GCC/ARMCMx/LPC11xx/vectors.s
+++ /dev/null
@@ -1,212 +0,0 @@
-/*
- ChibiOS/RT - Copyright (C) 2006,2007,2008,2009,2010 Giovanni Di Sirio.
-
- This file is part of ChibiOS/RT.
-
- ChibiOS/RT is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 3 of the License, or
- (at your option) any later version.
-
- ChibiOS/RT is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-.syntax unified
-.thumb
-
-.section vectors
-_vectors:
- .word __ram_end__
- .word ResetHandler
- .word NMIVector
- .word HardFaultVector
- .word MemManageVector
- .word BusFaultVector
- .word UsageFaultVector
- .word Vector1C
- .word Vector20
- .word Vector24
- .word Vector28
- .word SVCallVector
- .word DebugMonitorVector
- .word Vector34
- .word PendSVVector
- .word SysTickVector
- .word Vector40
- .word Vector44
- .word Vector48
- .word Vector4C
- .word Vector50
- .word Vector54
- .word Vector58
- .word Vector5C
- .word Vector60
- .word Vector64
- .word Vector68
- .word Vector6C
- .word Vector70
- .word Vector74
- .word Vector78
- .word Vector7C
- .word Vector80
- .word Vector84
- .word Vector88
- .word Vector8C
- .word Vector90
- .word Vector94
- .word Vector98
- .word Vector9C
- .word VectorA0
- .word VectorA4
- .word VectorA8
- .word VectorAC
- .word VectorB0
- .word VectorB4
- .word VectorB8
- .word VectorBC
-
-.weak NMIVector
-NMIVector:
-
-.weak HardFaultVector
-HardFaultVector:
-
-.weak MemManageVector
-MemManageVector:
-
-.weak BusFaultVector
-BusFaultVector:
-
-.weak UsageFaultVector
-UsageFaultVector:
-
-.weak Vector1C
-Vector1C:
-
-.weak Vector20
-Vector20:
-
-.weak Vector24
-Vector24:
-
-.weak Vector28
-Vector28:
-
-.weak SVCallVector
-SVCallVector:
-
-.weak DebugMonitorVector
-DebugMonitorVector:
-
-.weak Vector34
-Vector34:
-
-.weak PendSVVector
-PendSVVector:
-
-.weak SysTickVector
-SysTickVector:
-
-.weak Vector40
-Vector40:
-
-.weak Vector44
-Vector44:
-
-.weak Vector48
-Vector48:
-
-.weak Vector4C
-Vector4C:
-
-.weak Vector50
-Vector50:
-
-.weak Vector54
-Vector54:
-
-.weak Vector58
-Vector58:
-
-.weak Vector5C
-Vector5C:
-
-.weak Vector60
-Vector60:
-
-.weak Vector64
-Vector64:
-
-.weak Vector68
-Vector68:
-
-.weak Vector6C
-Vector6C:
-
-.weak Vector70
-Vector70:
-
-.weak Vector74
-Vector74:
-
-.weak Vector78
-Vector78:
-
-.weak Vector7C
-Vector7C:
-
-.weak Vector80
-Vector80:
-
-.weak Vector84
-Vector84:
-
-.weak Vector88
-Vector88:
-
-.weak Vector8C
-Vector8C:
-
-.weak Vector90
-Vector90:
-
-.weak Vector94
-Vector94:
-
-.weak Vector98
-Vector98:
-
-.weak Vector9C
-Vector9C:
-
-.weak VectorA0
-VectorA0:
-
-.weak VectorA4
-VectorA4:
-
-.weak VectorA8
-VectorA8:
-
-.weak VectorAC
-VectorAC:
-
-.weak VectorB0
-VectorB0:
-
-.weak VectorB4
-VectorB4:
-
-.weak VectorB8
-VectorB8:
-
-.weak VectorBC
-VectorBC:
-
-here: b here