aboutsummaryrefslogtreecommitdiffstats
path: root/os/nil/ports/e200
diff options
context:
space:
mode:
authorgdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-07-17 08:43:20 +0000
committergdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-07-17 08:43:20 +0000
commit6dee6a0bc925bc0567c41a74a64f5b9c88dc66bb (patch)
tree49808d290864fbeae50adde0de3768f2d70c7945 /os/nil/ports/e200
parent238790de5f6c1cc0c9db3fd83bf22b4e5b49d5f4 (diff)
downloadChibiOS-6dee6a0bc925bc0567c41a74a64f5b9c88dc66bb.tar.gz
ChibiOS-6dee6a0bc925bc0567c41a74a64f5b9c88dc66bb.tar.bz2
ChibiOS-6dee6a0bc925bc0567c41a74a64f5b9c88dc66bb.zip
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@7037 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/nil/ports/e200')
-rw-r--r--os/nil/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk14
-rw-r--r--os/nil/ports/e200/compilers/GCC/mk/port_spc560bxx.mk14
-rw-r--r--os/nil/ports/e200/compilers/GCC/mk/port_spc560dxx.mk14
-rw-r--r--os/nil/ports/e200/compilers/GCC/mk/port_spc560pxx.mk14
-rw-r--r--os/nil/ports/e200/compilers/GCC/mk/port_spc563mxx.mk14
-rw-r--r--os/nil/ports/e200/compilers/GCC/mk/port_spc564axx.mk14
-rw-r--r--os/nil/ports/e200/compilers/GCC/mk/port_spc56ecxx.mk14
-rw-r--r--os/nil/ports/e200/compilers/GCC/mk/port_spc56elxx.mk14
-rw-r--r--os/nil/ports/e200/compilers/GCC/mk/port_spc57emxx.mk14
9 files changed, 126 insertions, 0 deletions
diff --git a/os/nil/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk b/os/nil/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk
new file mode 100644
index 000000000..1e411c35b
--- /dev/null
+++ b/os/nil/ports/e200/compilers/GCC/mk/port_spc560bcxx.mk
@@ -0,0 +1,14 @@
+# List of the ChibiOS/RT e200z0 SPC560BCxx port files.
+PORTSRC = ${CHIBIOS}/os/nil/ports/e200/chcore.c
+
+PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560BCxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
+ $(CHIBIOS)/os/nil/ports/e200/compilers/GCC/ivor.s
+
+PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC560BCxx \
+ ${CHIBIOS}/os/nil/ports/e200 \
+ ${CHIBIOS}/os/nil/ports/e200/compilers/GCC
+
+PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/nil/ports/e200/compilers/GCC/mk/port_spc560bxx.mk b/os/nil/ports/e200/compilers/GCC/mk/port_spc560bxx.mk
new file mode 100644
index 000000000..86e4625a8
--- /dev/null
+++ b/os/nil/ports/e200/compilers/GCC/mk/port_spc560bxx.mk
@@ -0,0 +1,14 @@
+# List of the ChibiOS/RT e200z0 SPC560Bxx port files.
+PORTSRC = ${CHIBIOS}/os/nil/ports/e200/chcore.c
+
+PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560Bxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
+ $(CHIBIOS)/os/nil/ports/e200/compilers/GCC/ivor.s
+
+PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC560Bxx \
+ ${CHIBIOS}/os/nil/ports/e200 \
+ ${CHIBIOS}/os/nil/ports/e200/compilers/GCC
+
+PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/nil/ports/e200/compilers/GCC/mk/port_spc560dxx.mk b/os/nil/ports/e200/compilers/GCC/mk/port_spc560dxx.mk
new file mode 100644
index 000000000..80fb723be
--- /dev/null
+++ b/os/nil/ports/e200/compilers/GCC/mk/port_spc560dxx.mk
@@ -0,0 +1,14 @@
+# List of the ChibiOS/RT e200z0 SPC560Dxx port files.
+PORTSRC = ${CHIBIOS}/os/nil/ports/e200/chcore.c
+
+PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560Dxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
+ $(CHIBIOS)/os/nil/ports/e200/compilers/GCC/ivor.s
+
+PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC560Dxx \
+ ${CHIBIOS}/os/nil/ports/e200 \
+ ${CHIBIOS}/os/nil/ports/e200/compilers/GCC
+
+PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/nil/ports/e200/compilers/GCC/mk/port_spc560pxx.mk b/os/nil/ports/e200/compilers/GCC/mk/port_spc560pxx.mk
new file mode 100644
index 000000000..539d3a846
--- /dev/null
+++ b/os/nil/ports/e200/compilers/GCC/mk/port_spc560pxx.mk
@@ -0,0 +1,14 @@
+# List of the ChibiOS/RT e200z0 SPC560Pxx port files.
+PORTSRC = ${CHIBIOS}/os/nil/ports/e200/chcore.c
+
+PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560Pxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
+ $(CHIBIOS)/os/nil/ports/e200/compilers/GCC/ivor.s
+
+PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC560Pxx \
+ ${CHIBIOS}/os/nil/ports/e200 \
+ ${CHIBIOS}/os/nil/ports/e200/compilers/GCC
+
+PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/nil/ports/e200/compilers/GCC/mk/port_spc563mxx.mk b/os/nil/ports/e200/compilers/GCC/mk/port_spc563mxx.mk
new file mode 100644
index 000000000..fe52357b2
--- /dev/null
+++ b/os/nil/ports/e200/compilers/GCC/mk/port_spc563mxx.mk
@@ -0,0 +1,14 @@
+# List of the ChibiOS/RT e200z3 SPC563Mxx port files.
+PORTSRC = ${CHIBIOS}/os/nil/ports/e200/chcore.c
+
+PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC563Mxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
+ $(CHIBIOS)/os/nil/ports/e200/compilers/GCC/ivor.s
+
+PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC563Mxx \
+ ${CHIBIOS}/os/nil/ports/e200 \
+ ${CHIBIOS}/os/nil/ports/e200/compilers/GCC
+
+PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/nil/ports/e200/compilers/GCC/mk/port_spc564axx.mk b/os/nil/ports/e200/compilers/GCC/mk/port_spc564axx.mk
new file mode 100644
index 000000000..ae2c5ef3d
--- /dev/null
+++ b/os/nil/ports/e200/compilers/GCC/mk/port_spc564axx.mk
@@ -0,0 +1,14 @@
+# List of the ChibiOS/RT e200z4 SPC564Axx port files.
+PORTSRC = ${CHIBIOS}/os/nil/ports/e200/chcore.c
+
+PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC564Axx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
+ $(CHIBIOS)/os/nil/ports/e200/compilers/GCC/ivor.s
+
+PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC564Axx \
+ ${CHIBIOS}/os/nil/ports/e200 \
+ ${CHIBIOS}/os/nil/ports/e200/compilers/GCC
+
+PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/nil/ports/e200/compilers/GCC/mk/port_spc56ecxx.mk b/os/nil/ports/e200/compilers/GCC/mk/port_spc56ecxx.mk
new file mode 100644
index 000000000..d8b20f071
--- /dev/null
+++ b/os/nil/ports/e200/compilers/GCC/mk/port_spc56ecxx.mk
@@ -0,0 +1,14 @@
+# List of the ChibiOS/RT e200z4 SPC56ECxx port files.
+PORTSRC = ${CHIBIOS}/os/nil/ports/e200/chcore.c
+
+PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC56ECxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
+ $(CHIBIOS)/os/nil/ports/e200/compilers/GCC/ivor.s
+
+PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC56ECxx \
+ ${CHIBIOS}/os/nil/ports/e200 \
+ ${CHIBIOS}/os/nil/ports/e200/compilers/GCC
+
+PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/nil/ports/e200/compilers/GCC/mk/port_spc56elxx.mk b/os/nil/ports/e200/compilers/GCC/mk/port_spc56elxx.mk
new file mode 100644
index 000000000..0ef3765c0
--- /dev/null
+++ b/os/nil/ports/e200/compilers/GCC/mk/port_spc56elxx.mk
@@ -0,0 +1,14 @@
+# List of the ChibiOS/RT e200z4 SPC56ELxx port files.
+PORTSRC = ${CHIBIOS}/os/nil/ports/e200/chcore.c
+
+PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC56ELxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
+ $(CHIBIOS)/os/nil/ports/e200/compilers/GCC/ivor.s
+
+PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC56ELxx \
+ ${CHIBIOS}/os/nil/ports/e200 \
+ ${CHIBIOS}/os/nil/ports/e200/compilers/GCC
+
+PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/nil/ports/e200/compilers/GCC/mk/port_spc57emxx.mk b/os/nil/ports/e200/compilers/GCC/mk/port_spc57emxx.mk
new file mode 100644
index 000000000..82dd7f5fc
--- /dev/null
+++ b/os/nil/ports/e200/compilers/GCC/mk/port_spc57emxx.mk
@@ -0,0 +1,14 @@
+# List of the ChibiOS/RT e200z4 SPC57EMxx port files.
+PORTSRC = ${CHIBIOS}/os/nil/ports/e200/chcore.c
+
+PORTASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC57EMxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s \
+ $(CHIBIOS)/os/nil/ports/e200/compilers/GCC/ivor.s
+
+PORTINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC57EMxx \
+ ${CHIBIOS}/os/nil/ports/e200 \
+ ${CHIBIOS}/os/nil/ports/e200/compilers/GCC
+
+PORTLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld