aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32F4xx
diff options
context:
space:
mode:
authorgdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2013-09-02 09:53:58 +0000
committergdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2013-09-02 09:53:58 +0000
commit2254bd47344180d9ec99bd2226b6d45ed3b0f00e (patch)
tree5d3032c166bd08a1dbac03896dcac046c31d0743 /os/hal/ports/STM32F4xx
parent74b860fee65ca8feb2a796144976ff6c44e64bcc (diff)
downloadChibiOS-2254bd47344180d9ec99bd2226b6d45ed3b0f00e.tar.gz
ChibiOS-2254bd47344180d9ec99bd2226b6d45ed3b0f00e.tar.bz2
ChibiOS-2254bd47344180d9ec99bd2226b6d45ed3b0f00e.zip
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/branches/kernel_3_dev@6243 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/STM32F4xx')
-rw-r--r--os/hal/ports/STM32F4xx/platform.mk60
1 files changed, 30 insertions, 30 deletions
diff --git a/os/hal/ports/STM32F4xx/platform.mk b/os/hal/ports/STM32F4xx/platform.mk
index fdd725faf..d91d96409 100644
--- a/os/hal/ports/STM32F4xx/platform.mk
+++ b/os/hal/ports/STM32F4xx/platform.mk
@@ -1,33 +1,33 @@
# List of all the STM32F2xx/STM32F4xx platform files.
-PLATFORMSRC = ${CHIBIOS}/os/hal/platforms/common/ARMCMx/nvic.c \
- ${CHIBIOS}/os/hal/platforms/STM32F4xx/stm32_dma.c \
- ${CHIBIOS}/os/hal/platforms/STM32F4xx/hal_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32F4xx/adc_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32F4xx/ext_lld_isr.c \
- ${CHIBIOS}/os/hal/platforms/STM32/can_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/ext_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/mac_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/sdc_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/GPIOv2/pal_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/I2Cv1/i2c_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/OTGv1/usb_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/RTCv2/rtc_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/SPIv1/spi_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/TIMv1/gpt_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/TIMv1/icu_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/TIMv1/pwm_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/TIMv1/st_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/USARTv1/serial_lld.c \
- ${CHIBIOS}/os/hal/platforms/STM32/USARTv1/uart_lld.c
+PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
+ ${CHIBIOS}/os/hal/ports/STM32F4xx/stm32_dma.c \
+ ${CHIBIOS}/os/hal/ports/STM32F4xx/hal_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32F4xx/adc_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32F4xx/ext_lld_isr.c \
+ ${CHIBIOS}/os/hal/ports/STM32/can_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/ext_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/mac_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/sdc_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/GPIOv2/pal_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/I2Cv1/i2c_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/OTGv1/usb_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/RTCv2/rtc_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/SPIv1/spi_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/TIMv1/gpt_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/TIMv1/icu_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/TIMv1/pwm_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/TIMv1/st_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/USARTv1/serial_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/USARTv1/uart_lld.c
# Required include directories
-PLATFORMINC = ${CHIBIOS}/os/hal/platforms/common/ARMCMx \
- ${CHIBIOS}/os/hal/platforms/STM32F4xx \
- ${CHIBIOS}/os/hal/platforms/STM32 \
- ${CHIBIOS}/os/hal/platforms/STM32/GPIOv2 \
- ${CHIBIOS}/os/hal/platforms/STM32/I2Cv1 \
- ${CHIBIOS}/os/hal/platforms/STM32/OTGv1 \
- ${CHIBIOS}/os/hal/platforms/STM32/RTCv2 \
- ${CHIBIOS}/os/hal/platforms/STM32/SPIv1 \
- ${CHIBIOS}/os/hal/platforms/STM32/TIMv1 \
- ${CHIBIOS}/os/hal/platforms/STM32/USARTv1
+PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \
+ ${CHIBIOS}/os/hal/ports/STM32F4xx \
+ ${CHIBIOS}/os/hal/ports/STM32 \
+ ${CHIBIOS}/os/hal/ports/STM32/GPIOv2 \
+ ${CHIBIOS}/os/hal/ports/STM32/I2Cv1 \
+ ${CHIBIOS}/os/hal/ports/STM32/OTGv1 \
+ ${CHIBIOS}/os/hal/ports/STM32/RTCv2 \
+ ${CHIBIOS}/os/hal/ports/STM32/SPIv1 \
+ ${CHIBIOS}/os/hal/ports/STM32/TIMv1 \
+ ${CHIBIOS}/os/hal/ports/STM32/USARTv1